2

This problem is annoy me for a long time, but now i want to fix that finally. The problem is some Roboto fonts is not visible on pages.

I tried reinstall system (all except /home is new) several times (changing distros), but problem still exists.

In Chrome this issue is missing, he's rendering all as it must be.

I also tried to remove Roboto font from system completely, I tried to reinstall it. It's fixed just part of the problem.

enter image description here

This is how Amazon S3 control panels looks like to me.

enter image description here

Inspecting says the interface uses Roboto-Bold font from sytem, but i haven't Roboto-Bold font in the system. Why did he try to load it from system, not from web? This is the problem i see.

enter image description here

If i remove Roboto font from system, the most of the sites, which uses 'Roboto' is also come blank. F.e. YouTube will be completely white with pictures. For now on YouTube only tooltips has the problem.

enter image description here

How can i remove Roboto from system correctly or fix missing font. I tried to remove $HOME/.mozilla folder, but no results. As I say, this problem is only in FireFox, all Roboto fonts from system works perfectly in Chrome, LibreOffice, Inkscape and other programs.

My distribution KDE Neon, but this problem present in Ubuntu, Kubuntu and other distros i tried.

1

I had the same problem. While searching for a fix I came across the issue on gitlab https://gitlab.com/gitlab-org/gitlab-ce/issues/31389 and there someone suggested installing the roboto font on the system.

apt install fonts-roboto*

fixed it for me.

Why does gnome and firefox think that font is installed is another bug I guess. Hope this helps.

  • Didn't work for me :/ – Bach Nov 16 '17 at 14:32
0

I was able to fix a similar issue by installing

fonts-ubuntu-font-family-console

It seems my system was missing some core fonts that would render if original font wasn't found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.