Can someone please tell me how to download a driver to fix ubuntu 11.10 graphic driver problem (Radeon HD 6470) if I cant boot Ubuntu. I cannot set to acces with graphic commands so I am hoping I can download and run the driver to fix. Thanks for any help Tony

Thanks everybody for the suggestions I think I should give some further infomation. I think loading latest driver would be worth trying however from my login can someone explain if for instance I were to download the latest driver what command is needed to fetch the driver from say a pendrive? Also I ran STARTX and had a report 'Failed to load fgirx (module does not exist,0) is that relevant. Sound like its worth a try to install latest linux driver from ATI but can someone give me the commands to use to get to pendrive and run from my antony@antony-305V4A-305V4A:etc

Or how to move the driver on pendrive to home folder?etc.

Note: If I try to run sudo apt-get install fglrx -installer......it tells me unable to locate fglrx -installer

if I write sudo mount -t vfat /dev/sdb /mnt (where sdb is the flash) I get FAT-fs (sdb): bogus number on reserved sectors mount: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error. Have formatted the flash to Fat and again copied driver on. Need to update ati driver as cannot boot 11.10 Any ideas thanks

  • Why can't you boot Ubuntu? The built-in radeon driver should support your VGA. If you don't see any login screen, then you can press alt+ctrl+f1 to switch to a text-based login screen. You'll be able to install drivers from there. – Jo-Erlend Schinstad Dec 21 '11 at 20:19

By the laptop model you specify, I almost guarantee you are using a SAMSUNG laptop with an AMD APU, Oneiric has a bug that is only fixed with the last kernel update (which I think it was 3.0.0-16-generic).

In order to get it working under the A4, A6, or A8 APU, out of the box, download a minimal iso from Ubuntu, make a install, and it should be working.

You can get the minimal iso from here: Ubuntu Minimal CD

Why minimal CD?

The Minimal CD will download packages from online archives at installation time instead of providing them on the install CD itself. Only current packages are downloaded, so there is no need to upgrade packages immediately after installation. The Minimal CD uses a text-based installer like the Alternate CD, making the CD image as compact as possible.

Which in other words, means you will be getting the lastest kernel at install.

It is a known bug in Oneiric not supporting the APUs properly, which you can review here:

#825777 Display will not turn on in Oneiric with Llano APUs

HDMI should be working, so try using if you still get your screen turned-off. For what I know, VGA should not work without fglrx, only HDMI.

Or either, I think bug is already fixed on Precise Alpha 2. (If you have an A4 APU ONLY).

It is also a known bug that you might get "Wireless Device not Managed", in most cases, with the Atheros Wireless some SAMSUNG laptops ship with, which you can review here:

#929969 Atheros Wireless "device not managed"

A workaround for this instance is setting your wifi connection from the text-installer, (which is default on the minimal CD for 11.10, or the alternate-text-installer for 12.04 in case you have an A4.)

Either that or connecting to a wifi from the terminal.

If you get any issues, don't forget to ask. Good luck! ;)


The first step should here should be restoring the default drivers so you can boot to the desktop. I would recommend you log into the root recovery console and then clean up using the method described here.

Once you're back on the standard drivers, you should be able to do whatever you like.


If the desktop, live CD will not run, you can try installing from the alternate CD. Once your installation is finished, you will need to boot to recovery mode, which will give you a command line interface. From there you will need to download and install the driver.

Your problem is going to be that that card is not listed on the ATI compatibility list


In my experience, if the ATI card is not supported by the open source driver, and is not listed on that compatibility list, it is not possible to get running.

You can try to upgrade your graphics card , you can try an older version of Ubuntu, or you can try to install the driver.

There are detailed, step-by-step guides here



  • Can you go through the proceedure to install the driver without ubuntu booting? My options to download are either onto another laptop runing ubuntu or on to the laptop with the problem through windows as wget doesnt work as wifi etc not booted. I can save latest driver to a pendrive etc. Can you explain how to get it installed via usb after. Thanks – Antony Dec 22 '11 at 7:58
  • Do you have a local LUG or LoCo that might be able to help you ? – Panther Dec 22 '11 at 16:05

I have just recently (last night) been dealing with a very similar problem. The only real way to install the driver would be through recovery console (Select at boot up). It will then give you a command line with root privileges.

I would recommend downloading them on another computer and putting it on a flash drive. Bring it to the computer that won't boot, load recovery console, mount the USB Drive, and depending on your package use DPKG or ./****.run

  • Hi can you explain what you mean by 'Them here' when you say I would recommend downloading them on another computer and putting it on a flash drive.. Do you mean the driver? Can you explain the proceedure of DPKG or ./**.run a little better please.. Maybe ellaborate how sudo will\can see the pendrive with new driver etc.Thanks – Antony Dec 22 '11 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.