0

Im running ubuntu 16.04 LTS on my Lenovo ideapad 300 (i5 processor, 8gb ram)

The sound was working fine until this morning. It started to show up blank screen and some errors, something about the audio. I pressed the power button long enought to kill my pc because nothing else was working.

I reboot it, the sound was working fine, however I was unable to use volume keys or change volume via sound icon on menu bar.

Now that I reboot it again, the sound is completely gone.

I think I may have lost my drivers, nothing shows up in sound settings in output tab

However, aplay -l returns this:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20751/2 Analog [CX20751/2 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

if it helps

screen shot of my sound settings

EDIT: Just found out that audio works in 'videos' video player only.. I installed some software it suggested gstreamer or smth.. other than that my audio is a bust.. rhythmbox doesnt work, neither does youtube

  • sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-uname -r libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-uname -r libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g' whoami – RawWManN Mar 21 '17 at 11:22
  • Above did the trick for me.. lol solving my own questions Anyway, detailed info here: help.ubuntu.com/community/SoundTroubleshootingProcedure – RawWManN Mar 21 '17 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.