0

I want to install caffe at special version from GitHub: Caffe for Structurally Sparse Deep Neural Networks.

I have a problem about building caffe-scnn when I tried following these steps:

cd CAFFE_ROOT
mkdir build
cmake ..
make all

.....

Then I have problem about :

[ 1%] Built target proto
[ 90%] Built target caffe
Linking CXX executable caffe
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseSdense2csc'
 ../lib/libcaffe.so.1.0.0-rc3: undefined reference tocusparseSetMatType'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseScsrmm' 
../lib/libcaffe.so.1.0.0-rc3: undefined reference ocusparseDestroyMatDescr'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseDcsrmm2'
../lib/libcaffe.so.1.0.0-rc3: undefined reference tocusparseDdense2csc'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseDestroy'
 ../lib/libcaffe.so.1.0.0-rc3: undefined reference cusparseSetMatIndexBase'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseDnnz'
 ../lib/libcaffe.so.1.0.0-rc3: undefined reference ocusparseCreateMatDescr'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseCreate'
../lib/libcaffe.so.1.0.0-rc3: undefined reference tocusparseDcsrmm'
../lib/libcaffe.so.1.0.0-rc3: undefined reference to cusparseSnnz'
 ../lib/libcaffe.so.1.0.0-rc3: undefined reference tocusparseScsrmm2'
collect2: error: ld returned 1 exit status
make[2]: *** [tools/caffe] Error 1
make[1]: *** [tools/CMakeFiles/caffe.bin.dir/all] Error 2
make: *** [all] Error 2

How can I solve this problem?

(My OS is Ubuntu 14.04, and this is my result of cmake :

-- Boost version: 1.54.0
-- Found the following Boost libraries:
-- system
-- thread
-- filesystem
-- Found gflags (include: /usr/include, library: /usr/lib/x86_64-linux-gnu/libgflags.so)
-- Found glog (include: /usr/include, library: /usr/lib/x86_64-linux-gnu/libglog.so)
-- Found PROTOBUF Compiler: /usr/bin/protoc
-- Found lmdb (include: /usr/include, library: /usr/lib/x86_64-linux-gnu/liblmdb.so)
-- Found LevelDB (include: /usr/include, library: /usr/lib/x86_64-linux-gnu/libleveldb.so)
-- Found Snappy (include: /usr/include, library: /usr/lib/libsnappy.so)
-- CUDA detected: 7.5
-- Found cuDNN: ver. 5.0.5 found (include: /usr/local/cuda/include, library: /usr/local/cuda/lib64/libcudnn.so)
-- Added CUDA NVCC flags for: sm_52
-- OpenCV found (/usr/share/OpenCV)
-- Found Atlas (include: /usr/include, library: /usr/lib/libatlas.so)
Traceback (most recent call last):
File "", line 1, in 
ImportError: No module named numpy
-- Could NOT find NumPy (missing: NUMPY_INCLUDE_DIR NUMPY_VERSION) 
(Required is at least version "1.7.1")
-- Boost version: 1.54.0
-- Found the following Boost libraries:
-- python
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- Python interface is disabled or not all required dependencies found. Building without it...
-- ******************* Caffe Configuration Summary *******************
-- General:
-- Version : 1.0.0-rc3
-- Git : unknown
-- System : Linux
-- C++ compiler : /usr/bin/c++
-- Release CXX flags : -O3 -DNDEBUG -fPIC -Wall -Wno-sign-compare -Wno-uninitialized
-- Debug CXX flags : -g -fPIC -Wall -Wno-sign-compare -Wno-uninitialized
-- Build type : Release
-- BUILD_SHARED_LIBS : ON
-- BUILD_python : ON
-- BUILD_matlab : OFF
-- BUILD_docs : ON
-- CPU_ONLY : OFF
-- USE_OPENCV : ON
-- USE_LEVELDB : ON
-- USE_LMDB : ON
-- ALLOW_LMDB_NOLOCK : OFF
-- Dependencies:
-- BLAS : Yes (Atlas)
-- Boost : Yes (ver. 1.54)
-- glog : Yes
-- gflags : Yes
-- protobuf : Yes (ver. 2.5.0)
-- lmdb : Yes (ver. 0.9.10)
-- LevelDB : Yes (ver. 1.15)
-- Snappy : Yes (ver. 1.1.0)
-- OpenCV : Yes (ver. 2.4.8)
-- CUDA : Yes (ver. 7.5)
-- NVIDIA CUDA:
-- Target GPU(s) : Auto
-- GPU arch(s) : sm_52
-- cuDNN : Yes (ver. 5.0.5)
-- Documentaion:
-- Doxygen : No
-- config_file :
-- Install:
-- Install path : /home/s0606757/caffe-scnn/build/install
-- Configuring done
-- Generating done
-- Build files have been written to: /home/s0606757/caffe-scnn/build)
  • CUDA : Yes (ver. 7.5) – There you go: Caffee required CUDA v8.0+ (see caffe.berkeleyvision.org/install_apt.html). – David Foerster Mar 23 '17 at 10:01
  • @DavidFoerster OP states 14.04. Isn't CUDA v8.0+ only required for 16.04 as stated in the link you provided? – Elder Geek Mar 23 '17 at 14:54
  • 1
    @Welcome to AskUbuntu! Have you attempted to resolve the missing dependencies that your cmake output indicates that you require? Could NOT find NumPy (missing: NUMPY_INCLUDE_DIR NUMPY_VERSION) (Required is at least version "1.7.1") and Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) jump out at me. – Elder Geek Mar 23 '17 at 15:05
  • @ElderGeek: Yes, now that I read it again I understand the relationship between the versions of Ubuntu and CUDA the same way. The dependencies on NumPy and Doxygen are optional according to the installation instructions. – David Foerster Mar 23 '17 at 21:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.