5

My Dell T7610 with 2 x E5-2650V2 processors (each with 8 real cores, regular 2.6GHz, turbo 3.4GHz) is stuck at 1.2GHz and I am unable to get it to go faster. How do I get it to go at full speed?

I have followed the advice here to set the governor to "performance": similar question from a year ago. Except I was unable to do the "sudo update-rc.d ondemand disable" command as I got this error:

insserv: warning: current start runlevel(s) (empty) of script"ondemand"overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (2 3 4 5) of script"ondemand"overrides LSB defaults (empty).

And for a while the frequencies did go up, but now they are back at 1.2GHz and do not budge.

Geekbench verifies that this makes a real difference: Geekbench at 1.2GHz and Geekbench at higher freqs. As you can see, I was able to get it to run faster for a while but then it went back to 1.2GHz and the Geekbench load did nothing to change that.

I get this info for each of the 16 processor cores:

analyzing CPU 10:
driver: intel_pstate
CPUs which run at the same hardware frequency: 10
CPUs which need to have their frequency coordinated by software: 10
maximum transition latency: Cannot determine or is not supported.
hardware limits: 1.20 GHz - 3.40 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 1.20 GHz and 3.40 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency: 1.20 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
3100 MHz max turbo 4 active cores
3200 MHz max turbo 3 active cores
3300 MHz max turbo 2 active cores
3400 MHz max turbo 1 active cores

I have tried to adjust the minimum frequency, but the actual frequency stuck way below this minimum:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
2400000

  • 1
    Rebooted the computer and the frequencies worked fine for a while until at some point they all went to 1.2GHz and stayed there. The transition actually happened under load. Nothing seems to get them out of 1.2GHz. This is not thermal throttling as CPU temperatures were below 40 Celsius when the frequencies all went down. – Plato65 Mar 21 '17 at 10:13
  • 1
    So the computer keeps fluctuating between two states: 1) all cores stuck at 1.2GHz or 2) all cores flexibly changing frequencies. The computer switches between these states completely independently of temperature or load. Any thoughts? – Plato65 Mar 22 '17 at 23:58
  • 1
    I have the same problem here. I've been trying to sort it out but nothing seems to fix it. A reboot is only a temporary fix... – mihaimm Jun 28 '17 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.