I am trying to run conjure-up and i keep getting the following:

Traceback (most recent call last):
  File "/snap/conjure-up/133/bin/conjure-up", line 11, in <module>
  File "/snap/conjure-up/133/lib/python3.6/site-packages/conjureup/app.py", line 208, in main
  File "/snap/conjure-up/133/lib/python3.6/site-packages/conjureup/utils.py", line 129, in juju_version
    raise Exception("Could not determine Juju version.")
Exception: Could not determine Juju version.

I followed the simple guidline of the documentation running the following:

sudo snap install conjure-up --classic

Can I get any help,
Thank you


Check your juju version:

juju version

If output is something like this:

The program 'juju' can be found in the following packages:
* juju-2.0
* juju-1-default
Ask your administrator to install one of them

check your $PATH environment variable:

echo $PATH

If there is no path /snap/bin in the variable just add it like this:

export PATH="/snap/bin/:$PATH"
export PATH="/usr/bin/snap:$PATH"

Now, i hope, you can run conjure-up without errors.


I had the same error in a vm with Ubuntu-Server 16.04 LTS, the only thing needed to fix it was to update the system packages

sudo apt-get update
sudo apt-get upgrade

After updating it started properly when running "conjure-up"


I had to install juju from snap to make this work (tried above but did not work).

sudo snap install juju --classic

In some cases where you may have had previous deb installs of juju and/or conjure-up you may need to exit the shell (or logout completely) before the snap version of conjure-up works.


I had the same error message on ubuntu 16.04 i was able to fix the issue by running:

  1. sudo usermod -a -G lxd <USER>
  2. newgrp lxd
  3. conjure-up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.