1

I have tried an USB thermal printer to work on Ubuntu 16.04 with no success. All updates are installed.

I have tried with CUPS, installed the manufacturer .ppd file, but the print job just stays on the queue without print output.

I also have tried with usblp, the printer is on /dev/usb/lp0 but echo "test" >> /dev/usb/lp0 outputs nothing as it's waiting the writing feedback and nothing.

If I change the printer jumper to work as serial over usb, it works. I can print on /dev/ttyACM0 (but I don't want to change every printer on the company).

Any ideas what may be wrong? It does not seem anything with cups itself, it seems to be related to usb communication.

  • lsusb lists the device as Bus 001 Device 008: ID 1c8a:3012
  • lpinfo -v also list the device as direct usb://SWEDA/SI-300L?serial=0000000000002
  • dmesg:

    [ 1389.650521] usb 1-2: new full-speed USB device number 9 using xhci_hcd [ 1391.505603] usb 1-2: New USB device found, idVendor=1c8a, idProduct=3012 [ 1391.505608] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=6 [ 1391.505611] usb 1-2: Product: Printer Class [ 1391.505613] usb 1-2: Manufacturer: SAM4S CORP. [ 1391.505616] usb 1-2: SerialNumber: 0000000000002

UPDATE: Tested on a ubuntu 16.04 virtual machine on a windows host and it works. One difference that I noticed is that the virtual machine uses ohci-pci and the physical machine uses xhci_hcd.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.