1

I recently bought the LG 29UC88 widescreen monitor which has a resolution of 2560x1080 and operates at 60hz.

I also bought a card with the Radeon HD 7450 chipset to drive it. The attractive feature of this card is that the free radeon driver supposedly supports it quite well (see the "N. Islands column" of https://www.x.org/wiki/RadeonFeature/).

Unfortunately on Ubuntu 16.10 this card/monitor pair does not work out of the box (with an HDMI connection). I've managed to get the proper resolution using the card at 30hz instead of 60hz using hints from another post (https://askubuntu.com/a/818153/14747).

xrandr --newmode "2560x1080_30.00" 106.75 2560 2640 2896 3232 1080 1083 1093 1102 -hsync +vsync
xrandr --addmode HDMI-0 "2560x1080_30.00"
xrandr --output HDMI-0 --mode "2560x1080_30.00"

This is rather disappointing since the result is choppy. Does someone know how to get this this thing working at the full 60hz?

  • I've already tried the "reduced blanking mode" advice given here: forums.linuxmint.com/viewtopic.php?t=227205 – krumpelstiltskin Mar 20 '17 at 12:32
  • I actually have an HD 5450 but lspci gives the string: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos PRO [Radeon HD 7450] – krumpelstiltskin Mar 20 '17 at 13:13
  • Can You borrow from someone (or even buy) a DisplayPort cable and check it instead of HDMI ? – Michal Przybylowicz Apr 5 '17 at 9:35
  • @MichalPrzybylowicz: The card doesn't have a DisplayPort port. It does have a dual-link DVI which I haven't tried yet because the monitor doesn't have a DVI port, and I don't have the adapter. May try it in the future. – krumpelstiltskin Apr 6 '17 at 8:23
0

I may have answered my own question, but I'm not sure. The documentation for the Radeon HD 7450 (http://www.amd.com/Documents/AMD_Radeon_HD_7470-HD_7450_GPU_Feature_Summary.pdf)

HDMI 1.4a with Stereoscopic 3D Frame Packing Format, Deep Color, xvYCC wide gamut support,

Max resolution: 1920x1200

0

I have the same problem with an ATI HD6800 Series video card. Sadly for now the only option that worked with me is downgrade Ubuntu to 14.04.4 LTS and install the fglrx drivers.

It's the only thing that made 2560x1080 resolution work for me. Most likely this will also work for you since you have a more modern video card.

  • Thanks for the tip. Currently not an option for me... I'll just have to live with the low refresh :( – krumpelstiltskin Apr 6 '17 at 8:18
0

In case anyone else comes across this post and would like to see how it can end up solved (your mileage may vary):

Found some posts saying similar things like "can't get 2560x1080 out of an AMD card using radeon driver"

My specs are:

  • 6450, HDMI, OpenBSD.
  • I had a dual link DVI to HDMI cord which gave me a clue.

By using it I could get the output to supposedly be 2560x1080, however, it still wouldn't show up on screen correctly; it was very squished. Changing monitor to wide vs. original, etc. did not help. Finally ordered a full dual link DVI cable and by using it I can get 2560x1080 @ 60 Hz.

The key is in the HDMI specs of the card along with the support of the driver as linked by krumpelstiltskin. Basically, there is a pixel clock frequency difference between HDMI and DVI supported with the radeon driver.

If you're having issues, try something besides HDMI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.