2

Every time I log in gnome-software is using 100% of my cpu, and I assume it is because it checks for updates or something. Logging in is very slow, and I am not at all interested in these automatic update checks. I often update packages in terminal so I don't need this feature.

How can I disable it?

4

Ubuntu's software updater is not GNOME Software! GNOME Software does not listen to Ubuntu's software updater settings. I know this because I've got Ubuntu's updater set to run every other week, but I keep getting updates daily.

I found this on the Ubuntu forums, there is an edit on the original post with the solution to both problems. Use dconf-editor (may need to install), go to org.gnome.software, and uncheck "download-updates". GNOME Software should no longer check for updates, and Ubuntu's Updater should continue to update as usual. I'm not entirely sure, but I'm willing to bet you will need to log out and log back in for the change to take effect.

0

Disabling automatic updates can be done in the GUI:

-> System Settings 
-> Ubuntu Software & update 
-> Updates (tab) 
-> Automatic Check for updates 
-> Never
  • This solved my problem with slow login, but gnome-software is now using 100% of cpu a couple of seconds after I am logged in, why is this? Can I stop it from starting on login? – tjespe Mar 20 '17 at 13:44
0

I believe it inherits the Ubuntu system settings as per:

> System > Software &  Updates

in there, click on the "Updates" tab and choose "Never" for "Automatically check for updates".

This should give you what you want (but, then why ... ?)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.