1

I installed redis-server on Ubuntu 16.04 using apt.

It seems to auto-start at every boot-up by default

I don't like this, so I've tried the below commands:

sudo update-rc.d -f redis-server remove  # remove auto-start service
ls /etc/rc*.d | grep redis               # check service list, it prints nothing

It looks fine but redis-server is still auto-starting at every booting up.

Any suggestions?

4

Use the following command to disable the Redis server's service:

sudo systemctl disable redis-server
  • Thank you, it solves my issue. what is different between update-rc.d and systemctl command? – user3523935 Apr 4 '17 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.