0

I just created a bootable USB Linux Mint image. Everything worked fine but now i cannot format my USB pend drive. I tried to use dd if=/dev/zero of=/dev/sdb and udo mkfs -t vfat /dev/sdb but these gives me an error:unable to open /dev/sdb: Read-only file system. I also tried to use the command sudo hdparm -r0 /dev/sdb like it is suggested here, and this gave me the following output:

 /dev/sdb:
 setting readonly to 0 (off)
 readonly      =  0 (off)

But didn't solve the problem.

Do you have any suggestion to help me?

4
  • Did you try with elevated permissions (using sudo before the dd command line)? But dd is a dangerous tool. I suggest that you use mkusb, that wraps a safety belt around dd. See this link, askubuntu.com/questions/728289/re-use-of-ubuntu-live-usb/…
    – sudodus
    Mar 19, 2017 at 19:50
  • Of course I used sudo for each command. Now I also tried mkusb but I have still the same error
    – Niles
    Mar 19, 2017 at 21:06
  • Why don't you make a partition table, add a partition, and put a filesystem on the partition, like a normal USB would have.
    – ubfan1
    Mar 19, 2017 at 21:14
  • I am afraid that your USB pendrive is failing, that it is 'gridlocked'. But there are still a few things to try: 1. Try in other USB ports of the computer, 2. Try with another linux operating system, for example a live drive or 3. Try in another computer or 4. Try in a computer with Windows or MacOS. If still no luck, there are more details in the following link, ubuntuforums.org/…
    – sudodus
    Mar 20, 2017 at 7:35

0

Browse other questions tagged or ask your own question.