19

I am having major issues with Ubuntu touchpad on a Dell Latitude 3570 Laptop. If I use a USB mouse, everything works fine, but if I use a touchpad it is very hard to control. For example, if I want to click on something that is in the middle of the screen, I click, but for some reason Ubuntu THINKS I have clicked at the bottom Left-Hand corner of the screen, and thus opens the rubbish bin. It is REALLY making me angry.

I read somewhere that the following changes to synclient would fix it:

synclient FingerLow=9
synclient FingerHigh=10

These don't work. And in any case as soon as I reboot the machine, synclient resets back to defaults (FingerLow=25, FingerHigh=30), so even if they did work I would have to set them every time I rebooted the machine!

Is there anything else I can try? This is driving me insane. For the sake of my sanity, please help me before I smash up my laptop.

As requested, xinput list gives me the following:

⎡ Virtual core pointer                           id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLL06F3:00 06CB:75DA Touchpad             id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                         id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
   ↳ Virtual core XTEST keyboard                id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]
    ↳ DELL Wireless hotkeys                     id=16   [slave  keyboard (3)]
7
  • To make it easier to answer questions you should always include your dell laptop model number. Also in your particular case please edit your question and paste in the output from the terminal command xinput list - Thank you. Mar 19, 2017 at 18:46
  • @WinEunuuchs2Unix - I have made the necessary edits for you.
    – SamuelH
    Mar 19, 2017 at 19:01
  • My Dell Inspiron 17R 7720 SE uses this touchpad driver: ↳ AlpsPS/2 ALPS GlidePoint id=15 [slave pointer (2)] Although I'm not sure what difference that makes. However I have no problems with my touchpad the rare occasions I use it. Mar 19, 2017 at 20:24
  • @WinEunuuchs2Unix - how would I install that?
    – SamuelH
    Mar 19, 2017 at 22:47
  • 1
    Congrats! +1 to your question and +1 to your answer so others will follow in your footsteps (um touchpad fingerprints). Mar 20, 2017 at 1:12

9 Answers 9

9

Well, following advice from user WinEunuuchs2Unix, I DID google this. Apparently it is a major bug, has been since Ubuntu 14.04. Anyway, on the bug report page, a guy called Juan Hernandez (juanhm) suggested that installing xserver-xorg-input-libinput worked for him. I wanted to try this, so I typed:

sudo apt-get install xserver-xorg-input-libinput

and I got a message about broken dependencies, but it also said that the above package depended on xserver-xorg-core, so I tried running:

sudo apt-get install xserver-xorg-core

This installed a whole lot of xserver-xorg packages. I then ran:

sudo apt-get install xserver-xorg-input-libinput

and this time it worked. Next I rebooted, and tried to run:

sudo apt-get remove --purge xserver-xorg-input-synaptics

but it had already been removed. My touchpad in System Settings is now a very very simple dialogue, BUT the pointer doesn't seem to be jumping around anymore! The only disadvantage I can see is that I can no longer tap the touchpad to click (I have to use the buttons), but I wasn't doing that anyway!

So I do believe this is now working!

The bug report page is here: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1574667

I will update it to confirm that Juan Hernandez's suggestion worked.

3
  • didn't help: ``` xserver-xorg-core is already the newest version (2:1.19.6-1ubuntu4). xserver-xorg-input-libinput is already the newest version (0.27.1-1). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. ``` Jun 17, 2018 at 15:58
  • I have no clue what these steps did, but it helped (not 100%, but around 80% less jumps). (Ubuntu 18.04 on Panasonic CF-LX3)
    – rustyx
    Oct 14, 2019 at 20:14
  • This seemed to work for me too. My issue was different. My laptop touchpad (and possibly keyboard) seemed to have a very slight (200ms) lag that was driving me crazy. I tried a billion different things and this is what worked.
    – chimeraha
    Nov 21, 2021 at 1:01
4

In my case @SamuelH solution didn't work since everything was already installed and up to date. What I helped was

  • Disable Natural Scroll
  • Enable Edge scrolling
  • Reduce touch pad speed
  • Disable Tap to click

Machine:

Dell E6540

OS:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04 LTS
Release:    18.04
Codename:   bionic
1
  • 1
    I think disabling natural scrolling alone fixed it for me. Thanks. Apr 9, 2021 at 1:29
3

I am using Razer Blade Early 2017 and my touchpad is Synaptics TM2438-005 running Ubuntu 18.04 Bionic Beaver

I was looking everywhere for a solution and had to dig through the history of synclient, being replaced by libinput and the corresponding cli tool xinput.

But this article solved my problem and more specifically, simply installing libinput-tools

$ sudo apt install libinput-tools

Bionic Beaver is not using Unity as a GUI server but uses Gnome instead, so I am guessing all the dependencies are in there already (xserver-core, libinput etc.)

For anyone who is having issues on Ubuntu 18.04 - this solved my problem and I have a semi-working touchpad now. It still jumps occasionally, but that's once per 10 new touch presses, it used to be every ~millisecond.

1
  • 1
    I also am having the same problem of my touch pad skipping on the razer blade 2018. What would installing libinput-tools do? I am quite new to ubuntu so I'm not sure if just installing it is good enough to fix the problem. Mar 1, 2019 at 3:27
2

After upgrading to Ubuntu 20.04 from Ubuntu 19.10, I started facing this issue of jumping pointer. My Laptop and OS details:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:  Ubuntu 20.04 LTS
Release:  20.04
Codename: focal

$ xinput list
⎡ Virtual core pointer                      id=2  [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4  [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12 [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3  [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5  [slave  keyboard (3)]
    ↳ Power Button                              id=6  [slave  keyboard (3)]
    ↳ Video Bus                                 id=7  [slave  keyboard (3)]
    ↳ Power Button                              id=8  [slave  keyboard (3)]
    ↳ Lenovo EasyCamera: Lenovo EasyC           id=9  [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=10 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11 [slave  keyboard (3)]

These packages were already installed: xserver-xorg-input--libinput, xserver-xorg-input-libinput, xserver-xorg-core, no -broken dependencies, apt autoremove and apt autoclean already cleaned the OS.

I coundn't find the xserver-xorg-input-synaptics package

"as answered by SamuelH in this post answers where he removed it to solve this problem"

I decided to install it to see the results. It worked for me and the problem was gone. My tap functions are also working fine.

$ sudo apt install xserver-xorg-input-synaptics
1
  • It also worked for a Lenovo ThinkPad E430 with a Synaptics touchpad and Ubuntu 20.04. You can check if the synaptics driver is already installed with apt list --installed | grep xserver-xorg-input*, as mentioned here
    – FairMiles
    Sep 29, 2020 at 20:14
1

Please refer to this solution by Alucard

I have tested this with the same laptop being a Latitude E5470 running Bionic Beaver with all the latest updates.

It would seem that the pointer stick or the "nipple" is what causes the cursor to randomly jump. If you have your backlit keyboard enabled you will see it switch on when the cursor jumps.

For ease of use I will paste Alucard's solution below:

1) Type in terminal:

xinput list

Look for something like "AlpsPS/2 ALPS DualPoint Stick". Look for a field "ID=xxx" of that particular device.

2) Type in terminal:

xinput -list-props {ID of Dualpoint Stick}

One of the lines should be something like: "Device Enabled (142): 1" Take note of the ID, which is 142 in this case).

3) Disable Dualpoint Stick: (Setting value to 0 is the same as disabling the device)

xinput -set-prop {ID of Dualpoint Stick} 142 0
0

I had this same issue. I solved it by installing Ubuntu 16.04 then updating to 18.04. I think it is some problem with the firmware.

0
0

I have an HP ZBook Studio G4, with Ubuntu 20.04. I'v been experiencing problems with the touchpad whereas using xserver-xorg-input-libinput would make dragging and text selection impossible by jumping the pointer to the starting location while dragging with the secound touch finger, while using synaptics drivers fixed this issue but made the touchpad not disabling while typing.

Following @SamuelH's steps BUT installing xserver-xorg-input-synaptics made the touchpad working properly.

The installed packages are:

xserver-xorg-input-synaptics/focal,now 1.9.1-1ubuntu3 amd64 [installed]
xserver-xorg-input-wacom/focal,now 1:0.39.0-0ubuntu1 amd64 [installed,automatic]
xserver-xorg-core/focal-updates,focal-security,now 2:1.20.9-2ubuntu1.2~20.04.2 amd64 [installed]
libinput-tools/focal-updates,now 1.15.5-1ubuntu0.2 amd64 [installed]
0

To disable the touchpad and enable only the external mouse, the following solution worked for me (on 20.04):

sudo apt install dconf-editor

dconf-editor

Now you can try any of these, depending on what options your specific laptop shows:

org--gnome--settings-daemon--peripherals--touchpad/touchscreen
    -> disable it

org--gnome--desktop--peripherals--touchpad--send-events
    -> disable default value
    -> select disabled-on-external-mouse
-2

I had the same problem with my computer. I went through the various fixes and found there are several reasons for the problem consequently several different possible solutions. I isolated the hard drive with no change. The problem was not in the HD. I isolated the bios and cashe with no change. The only thing left since I have a touch screen was the touch screen chip. To fix that I simple put my finger on the icon as it rested in the upper left corner of the screen and dragged it down to the centre of the screen. It worked for a few minutes then went back to the corner again. I used my finger on it again this time it stayed and has not acted erratic again. Hope this helps.

1
  • 2
    I suggest you make a self-answered question about this with full details, instead of posting an answer where it doesn't belong to a hardware-specific question about a different device
    – Zanna
    Oct 15, 2017 at 7:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .