0

This looks like a not-so-complicated dependency conflict, but I'm far to be an apt specialist. I can't find people that have the same problem as me (although I don't know what I have done to get this error).

Background: I have Google Chrome's repository configured. When I try to install it, dpkg crashes:

⚡ LANG=en_US.UTF-8 sudo apt install google-chrome-stable 
Reading package lists... Done
[TRUNCATED]
The following packages have unmet dependencies:
 google-chrome-stable : Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try to install libpango1.0-1:

⚡ LANG=en_US.UTF-8 sudo apt install libpango1.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpango1.0-0 : Depends: libpango-1.0-0 (= 1.40.1-1ubuntu1) but 1.40.3-2~ubuntu16.10.1 is to be installed
                 Depends: libpangocairo-1.0-0 (= 1.40.1-1ubuntu1) but 1.40.3-2~ubuntu16.10.1 is to be installed
                 Depends: libpangoft2-1.0-0 (= 1.40.1-1ubuntu1) but 1.40.3-2~ubuntu16.10.1 is to be installed
                 Depends: libpangoxft-1.0-0 (= 1.40.1-1ubuntu1) but 1.40.3-2~ubuntu16.10.1 is to be installed
E: Unable to correct problems, you have held broken packages.

This output from apt policy looks strange to me:

⚡ LANG=en_US.UTF-8 apt policy libpango-1.0-0     
libpango-1.0-0:
  Installed: 1.40.3-2~ubuntu16.10.1
  Candidate: 1.40.3-2~ubuntu16.10.1
  Version table:
 *** 1.40.3-2~ubuntu16.10.1 100
        100 /var/lib/dpkg/status
     1.40.1-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages

From where that 1.40.3-2~ubuntu16.10.1 version comes from, when Ubuntu's archives only have version 1.40.1-1ubuntu1 ? Looks like the problem comes from here?

I originally thought it was specific to Chrome, but it also happens with other packages, like unity-editor (Unity 3D editor for Linux, installed from a .deb).

apt also suggests me to run apt -f install. If I do this, it simply cleanly uninstalls "broken" google-chrome without fixing anything.

  • I know late but .. usually this happens if you use older .deb files which (like in your case) depend on outdated packages. Normally this shouldn't happen using the newest .deb files – derHugo Apr 17 '17 at 16:18
1

So, I was lost yesterday but... looking at the problem again, it seemed much more clear.

My intuition about the output of apt policy was right, I don't know how, but a recent version of libpango was installed, at least a more recent version than the one Ubuntu provides: 1.40.3-2~ubuntu16.10.1 against 1.40.1-1ubuntu1. The version conflict comes from here.

So, I've downgraded those libpango-related libraries to the version the main repository provides:

sudo apt install libpango-1.0-0=1.40.1-1ubuntu1 libpangocairo-1.0-0=1.40.1-1ubuntu1 libpangoft2-1.0-0=1.40.1-1ubuntu1 libpangoxft-1.0-0=1.40.1-1ubuntu1

The libraries listed in that command are the ones that are listed in apt policy's output above.

And boom, that works!

Just a bit surprised that nobody posted an answer or a little comment, you guys don't like to farm reputation anymore?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.