0

I had pgadmin4 v1.0, then I updated it without any problem to v1.1 and then v1.2.

After v1.3 was released I tried to do the update to v1.3. I followed the same steps as I did before. (Similar to How to install pgAdmin 4 in desktop mode on Ubuntu 16.04 but using conda to create the virtual environment and with python 3.5, I also tried with conda + python 3.6 and with virtualenv and python 2.7 and I got the same result)

However, after the install was done I launched pgAdmin4 and I got the following error message that popped up in a modal:

Error loading script - /sqleditor/sqleditor
Error message
undefined

Nothing appears in the terminal.

This error appears in the browser console: GET http://localhost:5050/lib/codemirror.js [HTTP/1.0 404 NOT FOUND 6 ms]

I rolled back to v1.2, which still works fine and I have no idea how to solve this issue.

I had the issue with both Ubuntu 14.04 and Ubuntu 16.04 with Firefox 52.0 64 bits.

  • What is your Browser name & version? I tested with Chrome v.56 & Firefox v.52 and it is working fine. – n33rma Mar 20 '17 at 12:51
  • @n33rma: Firefox 52.0 64 bits. – Antoine Dusséaux Mar 20 '17 at 17:29
  • Can you provide error/screenshot from browser console? – n33rma Mar 21 '17 at 4:54
  • Here it is: i.stack.imgur.com/pE5Co.png @n33rma thanks to enjoypb – Antoine Dusséaux Mar 23 '17 at 9:49
  • This are from Windows system, I am not sure about Windows as I tested on Ubuntu only. – n33rma Mar 23 '17 at 12:23
0

You need to deactivate the virtualenv and create a new one.

 $  deactivate

In doing that you need to re-run setup.py:

If the path to v1.3 is different then make sure to change PGADMIN4_SRC to point to new location. Create a new web/config_local.py with the values you want.

Create the new venv

$ mkvirtualenv pgadmin4
and/or
$ workon pgadmin4

Then run

 $ python  $PGADMIN4_SRC/web/setup.py 

Then you can start

 $ python  $PGADMIN4_SRC/web/pgAdmin4.py

The sqleditor/sqleditor error should no longer appear.

  • I tried and it didn't help. What is the web directory? – Antoine Dusséaux Apr 8 '17 at 20:36
  • My instructions work for source - sorry. – Al_Lusive Apr 9 '17 at 23:46
  • My instructions work for source - sorry. The web directory does not exist in the pip version. Did you create a brand new virtualenv - like virtualenv pgadmin4_1.3 – Al_Lusive Apr 10 '17 at 0:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.