11

I have Ubuntu 16.04 installed on a Dell XPS 15 9550. When I power on the laptop with headphones plugged in, they are not detected by the system and they are not even visible in the audio settings.

In order to make them work properly, I have to unplug the jack and reboot the machine. Even though it's not a big issue, it can be very annoying if I don't remember to unplug headphones before startup.

How can this be fixed?

Thanks in advance for the help!

  • Maybe this helps askubuntu.com/questions/769593/… – M. Becerra Mar 19 '17 at 10:05
  • Unfortunately no, it doesn't. My headphones are not even detected as output device. If there's any log that I can provide to help, I'll add it to the question – Andre Mar 19 '17 at 10:44
  • 1
    I have the same problem with my Inspiron 7559, running ubuntu 16.04. So far I haven't found a solution, have to manually remove & insert headphones at each startup. – zindarod Jun 6 '17 at 16:30
  • I have the same problem with different hardware. No solution yet. – Dr_Zaszuś Oct 12 '17 at 15:46
0

I have an Dell Inspiron 15-3567 with the exact same issue. I follow this thread : Make PulseAudio prefer external audio device

Adding load-module module-switch-on-connect seems to do the job.

  • 1
    this only crashed my system. – Tom Mercer Jun 4 '18 at 23:34
0

this works for me on 18.04, I had several problems and now all solved, try these steps I hope it help.

Step One (headset instead of headphone)

if you have a headset with one jack for both Mic and headphone and it's not working you need to do these :

check if your last three line of /etc/modprobe.d/alsa-base.conf be :

options snd-usb-audio index=-2
options snd-hda-intel position_fix=1
options snd-hda-intel model=,dell-headset-multi

you probably don't have the last two lines, add them at the end of the file and save it. with these settings whenever you plugged your headphone into your PC/laptop ubuntu asks you if it's a headset a Mic or a headphone.

Step Two (echo cancellation)

for disabling echo cancellation and some noise open this file :

/etc/pulse/default.pa

and add

load-module module-echo-cancel

some where into it.

and finally Step Three (your answer)

with this method you can restart your audio card module so your headphone can work again without restarting your PC/Laptop :

sudo modprobe snd-hda-intel

it should work :) for doing this at startup do this :

sudo sh -c 'echo "snd-hda-intel" >> /etc/modules'

and even if this method didn't work too :/ you need to disable the secure boot as mentioned here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.