I installed CUDA with

sudo dpkg -i cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb
sudo apt-get update
sudo apt-get install cuda

I then tried sudo add-apt-repository ppa:graphics-drivers/ppa and sudo apt-get install nvidia-current

After typing dpkg -l | grep -i nvidia, I see nvidia-375 and nvidia-378

However, I then tried nvidia-smi and got

WARNING:root:could not open file '/etc/apt/sources.list.d/osmosa-ubuntu-audio-recorder-xenial.list'

nvidia-smi: command not found

Can anyone help with this?

  • did you try running sudo apt update after running sudo add-apt-repository ppa:graphics-drivers/ppa and before running sudo apt-get install nvidia-current? – Yaron Mar 19 '17 at 8:28
  • I did run sudo apt update. I don't remember if it was before sudo apt-get install nvidia-current – user5739619 Mar 19 '17 at 8:34
  • please restart your Ubuntu machine, and check if it solve the problem – Yaron Mar 19 '17 at 8:39
  • 1
    I did restart, and I still get the same error with nvidia-smi – user5739619 Mar 19 '17 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.