8

I'm installing docker on Ubuntu 16.04. I'm following all the instructions on https://store.docker.com/editions/community/docker-ce-server-ubuntu?tab=description

(That instructions are the same on https://docs.docker.com/engine/installation/linux/ubuntu/ but cleaner).

When I launch the step "2. Get Docker CE", it doesn't find the docker-ce package:

me@mypc:~$ sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package docker-ce

I've checked and the repo has been added. I've updated my system, but I don't get the package:

Docker repo added

Does anyone knows what is wrong here?

3
  • 1
    Whats the output of sudo apt-get update ? – M. Becerra Mar 18 '17 at 23:54
  • It shows a Get in all the repos and a Hit on the docker one – Federico J. Mar 19 '17 at 0:09
  • Just thinking, may it be that the release i386 is a 32 bits and that's not supported by docker? – Federico J. Mar 19 '17 at 0:10
5

It's not working because the Ubuntu installed is a 32 bits one (as you can see from the repo image, it's the i386 one).

And the installation guide from Docket clearly states:

OS requirements

To install Docker, you need the 64-bit version of one of these Ubuntu versions:

  • Yakkety 16.10
  • Xenial 16.04 (LTS)
  • Trusty 14.04 (LTS)

I've installed a 64 bits, and all works correctly.

3
  • 2
    I have 64 bit and I'm getting the OP's error – ahnbizcad Apr 22 '17 at 23:40
  • Same as @ahnbizcad, me too, I have the 64 bit version and I get the same error. – danidemi May 4 '17 at 10:39
  • 1
    I opened a similar question on "Linux and Unix" that maybe can add some advice for some users. – danidemi May 5 '17 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.