3

I have Lubuntu 16.04.2. System boot from Internal HD. User name is 'ale' Everything looks great, so far.

I have connected an External HD named as 'Aquarius' When boot this EHD is mounted with 'root', since at File Properties at tab Permissions, it says Owner:root, Group: root

From terminal I run: sudo chmod -R 777 /mnt/Aquarius and then I run: sudo chown -R ale:ale /mnt/Aquarius but I got the message 'chown changing ownership operation not permitted'

2

Some filesystems (e.g., FAT32) don't support per-file owners, groups, or permissions. You can only set permissions on them filesystem-wide, and you do so via a mount option: mount -o uid=123,gid=123,umask=0000 /dev/whatever /mnt/Aquarius

Source: man mount

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.