1

For whatever reason VLC disappeared. I really can't remember if it were something I did or some weird update. Whatever the case the program wasn't opening but I could see that it was still installed. I purged it and I've been trying to get it re-installed ever since.

sudo apt install vlc gives the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
E: Unable to correct problems, you have held broken packages.

This didn't feel right. So I google broken package errors for solutions and most commonly it was running sudo apt clean or doing it from within Synaptic. I've done both to no avail.

Next I assume the package does need to be installed, I open up Synaptic and search for this libgles... find the packages, hit install...error. This package depends on libglapi-mesa, I search for it and find that it's already installed. At this point I've followed the rabbit hole and don't know where to go now.

http://imgur.com/a/rNfMY

1

I had a similar problem after a Synaptic update this morning. VLC was removed as part of that update. When I tried to reinstall, I ran into the unmet dependency problem with libgles1-mesa. I was able to reinstall VLC after I purged the ubuntu-x-swat PPA, which I had added to my system. I am currently running Lubuntu 16.04.02 LTS. You might want to check if that PPA is in your repositories.

  • Thanks for the advice but as mentioned in the answer I gave and marked as solved. I updated to 17.04 and now it works, not a real solution I grant you but it did the job. – shmink Apr 4 '17 at 15:20
0

I do not know the cause of the problem, but I did upgrade from Ubuntu 16.04.2 to Ubuntu 16.10 to Ubuntu 17.04 . - I used this PPA: videolan-ubuntu-stable-daily-zesty

I have found this solution:

  • 1) sudo apt update
  • 2) sudo apt dist-upgrade
  • 3) sudo apt install -f
  • 4) Reboot
  • 5) With Synaptic Package Manager i removed all vlc-* packages of version 1:2.2.1-dmo3**
  • 6) After with Synaptic i installed VLC version 2.2.4-14ubuntu2 default version for Ubuntu 17.04
-1

I don't know the solution in this scenario but I went ahead and upgraded to 16.10. Tried all these steps again and no change. I thought I may as well update to 17.04 seeing as I already don't have everything set up the way I want and I would upgrade to anyway when it's released. Repeating the steps again it now works in 17.04. So as stated I'm not sure how this solved the problem but it has in my situation, your mileage may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.