I've got an Ubuntu 11.10 system connected via a proxy to the internet, and I would like to install packages via apt-get. When I try to do that I get this error message:

sudo apt-get install libboost-program-options-dev
Err http://gb.archive.ubuntu.com/ubuntu/ oneiric/main libboost1.46-dev i386 1.46.1-5ubuntu2
407  Proxy Authentication Required

Any ideas?

  • is their any free proxy details available so that i can connect and download some packages @ my office. – Jaison Justus Oct 16 '12 at 4:50

This method worked for me.....just have a try...

check the file /etc/apt/apt.conf

The contents were,

Acquire::http::proxy "http://<proxy>:<port>/";
Acquire::ftp::proxy "ftp://<proxy>:<port>/";
Acquire::https::proxy "https://<proxy>:<port>/";

This was the reason why you could reach proxy but couldn't get past it, since there is no username password information. So just put that info into it..

Acquire::http::proxy "http://<username>:<password>@<proxy>:<port>/";
Acquire::ftp::proxy "ftp://<username>:<password>@<proxy>:<port>/";
Acquire::https::proxy "https://<username>:<password>@<proxy>:<port>/";

save the file and you are done...

BROTIP: More better add these lines in another file, /etc/apt/apt.conf.d/80proxy. This will ensure that after a version upgrade changes won't be lost.

  • 1
    <br> What if in the username there is a "@" char. <br> For example if the username is a complete email address? – user247735 Feb 13 '14 at 8:08
  • 1
    @Hunger, refer this cyberciti.biz/faq/…. – Vineet Menon Feb 14 '14 at 10:57
  • 2
    if you doing this in the morning, don't forget to delete the chevrons – ldgorman Mar 5 '14 at 10:49
  • Acquire::socks::proxy "socks5://server:port"; – Kris Roofe Dec 29 '16 at 1:56

To configure a proxy temporary, set the http_proxy environment variable. If the proxy is proxy.example.com on port 8080 and you need to authenticate with username user and password pass, run:

sudo http_proxy='http://user:pass@proxy.example.com:8080/' apt-get install package-name

To set such a proxy permanently, create /etc/apt/apt.conf.d/30proxy containing:

Acquire::http::Proxy "http://user:pass@proxy.example.com:8080/";

The changes are immediately visible the next time you run apt.

  • 2
    It's still not working, same error. I should mention I have my proxy set up globally on Applications -> System Tools -> System Settings -> Network Proxy -> Apply system Wide – 719016 Dec 21 '11 at 14:44
  • The proxy connection works for me (tested with netcat as well as Squid). What proxy server is in use? Some proxies may need other authentication methods. – Lekensteyn Dec 21 '11 at 17:34
  • +1 temporary workaround was a more suitable answer for me! – wim Nov 21 '12 at 4:56
  • 1
    @Lekensteyn : why did you choose the '30' prefix? i now it define the order of parsing, but: is there a convention about 30 for proxy? – jgomo3 Feb 13 '14 at 18:35
  • 1
    @jgomo3 I probably looked at the other files (or a README in that directory if it exists?) and then picked a value at random. The files are read in alphabetical order. – Lekensteyn Feb 13 '14 at 23:36

An alternative is to use Synaptics Package Manager, setting in its Preferences the proxy to which you want to connect. You can find the configuration using this path: Settings -> Preferences -> Network

protected by Community Jul 7 '14 at 8:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.