1

I'm trying to get all my documents scanned and throw away those nasty papers. To simplify this process I recently bought a Brother ADS-2100e scanner. I thought this scanner could create OCR-PDF on USB-Stick but I'm wrong. The PDFs on USB are not searchable. So I'm trying to add OCR afterwards with pdfsandwich. This worked, but my PDF-Viewer (Evince, Ubuntu 16.04.2) could not find a single word. Every word got whitespaces after every char. I choose the right tesseract-language-pack but the "whitespace-problem" won't go away.

Example: The word "Guten" could only be found with "G u t e n" and so on.

I tried to search this single PDF-File with PDF-XChange-Viewer on Windows 10 and everthing works fine. No whitespaces after every char.

I tried other PDF-Viewers and Search-Tools on Ubuntu (recoll, pdfgrep, qpdfview, Okular). Every single tool only shows me those whitespaces. Is there anything I can do?

In most cases I only need some words from the pdf-file to find it with recoll, but with whitespaces I is not possible to find any of them.

I don't think tesseract is my problem. It seems that PDFViewers and Search-Tools got a problem to read OCR-text.

This problem is already discussed here:

https://bugs.ghostscript.com/show_bug.cgi?id=696116

I could fix my problem with a little workaround:

I don't create PDF-files on USB-Stick but JPEG-files. Those JPEGS could easily transformed to searchable PDF-files with:

tesseract -l [LANGUAGE] [INPUT-PICTURE] [OUTPUT-FILE-NAME] pdf

Now I got my searchable PDF-files, but my first problem ist not solved yet.

1
  • Could you scan and post a non-sensitive example document as the JPEG and generated PDF file so that we can try reproducing the issue? May 5 '20 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.