1

This problem developed after I updated Ubuntu. I have tried purging and reinstalling nautilus but the problem persists.

This is the output from terminal when I run it:

(nautilus:12554): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist

(nautilus:12554): GVFS-WARNING **: can't init metadata tree /home/ozuf/.local/share/gvfs-metadata/home: open: Permission denied
**
ERROR:nautilus-canvas-container.c:6021:finish_adding_new_icons: assertion failed: (!container->details->auto_layout)
Aborted (core dumped)

Please do you have any idea what the problem is and how to fix it?

3
  • @M.Becerra it saya bash: cd: /home/ozuf/.local/share/gvfs-metadata/home: Not a directory
    – X09
    Mar 17 '17 at 17:24
  • My bad, made a mistake. This one is correct ls -l /home/ozuf/.local/share/gvfs-metadata/home
    – M. Becerra
    Mar 17 '17 at 17:28
  • -rw------- 1 root root 29508 Oct 22 22:21 /home/ozuf/.local/share/gvfs-metadata/home
    – X09
    Mar 17 '17 at 17:31
1

As you can read from the error message:

/home/ozuf/.local/share/gvfs-metadata/home: open: Permission denied

And confirmed by:

ls -l /home/ozuf/.local/share/gvfs-metadata/home

-rw------- 1 root root 29508 Oct 22 22:21 /home/ozuf/.local/share/gvfs-metadata/home

The file needed by Nautilus is owned by root, so you would need to run Nautilus with sudo, which you shouldn't.

To change the ownership back to your user

You can simply get the ownership of the whole directory, as it's likely some more files will be owned by root and could cause trouble in the future.

cd ~/.local/share 

sudo chown $USER -R ./gvfs-metadata

That fixes the permission problem. To fix the second problem which is

ERROR:nautilus-canvas-container.c:6021:finish_adding_new_icons: assertion failed: (!container->details->auto_layout`:
  1. From home, run cd .config and rm -rf nautilus

  2. Also from home run .local/share and rm -rf nautilus.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.