5

I use nemo file manager on Xubuntu 16.04.

I have connected several network shares. I have also bookmarked them. In nemo I can access all files. When I try to open a file with an application I do get a standard file open dialog that does not have those shares. There is "Other locations" but that only gives the mounted driver. No bookmarks, no network shares.

In essence, I do not know how to open any network file in Xubuntu with an application. Only workaround I see is to copy all files to home, open them there and when done store them back to a network share. I am sure there must be another way. Please help!

PS: I think this is not specific to Xubnutu desktop. Its the same when I select thunar as preferred file manager.

1
  • It's unfortunate this is still an issue.
    – Constantin
    Dec 6, 2017 at 16:05

3 Answers 3

1

I have found an answer, but I do hope its not the best one. I found it in that post: https://forums.linuxmint.com/viewtopic.php?t=144053. Its a workaround, really.

The desktop file managers mount network shares not in the home directory, but in the the linux directory tree. Actually an idea with consequences, because network shares contain user permissions. That means not every user is able to get access to very share. That means you can have the same share connected by different users at the same time, each with different permissions. That means, that the share can not be stored by share name, but there must be a destinction by user.

So in my case they have decided to put all shares mounted by a file manager to

 /run/user/1000/gvfs/

In that directory are all shares. The 1000 is my current the 'user id'. On a system with multiple users it could be 1061 or whatever. 'gvfs' is about the file system technology involved. The names are a bit cryptic like 'smb-share:server=myserver,share=images' but at least recognizable. Currently I fail to see the advantage compared to /home/username/shares, or ~/shares, which would be accessible from each application with 2 clicks. maybe someone can enlighten me.

So as described in the post the workaround is based on the fact that local bookmarks actually are listed in the file open dialogs (shares are not). So just goto your version of

 /run/user/1000/gvfs/

and add a bookmark. That is listed in the file open dialog, and then you are in the list of shares. You see a bookmark 'gvfs' which you can rename to "Network Shares"

So its solved principally and its event 2 clicks only, but it still somehow is a very bad solution and a workaround. I still can not browse the network. I can not see anything when I did not mount the share in a file manager. All the function is already there in the file manager, what could possibly block a decision to expose that function to the file open dialog? Please do not hesitate to add a comment that help a new user to understand that.

Thanks and hope for better answers.

1

I think this is due to this bug:

https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1714518

There is a patch for it available and I guess it may be solved in future updates. I am sorry but I cannot tell you how to install the patch because I don't know how to do it myself.

0

Since I got no other feedback for some time the official answer to the question is "Not possible".

The rest of this answer provides the best workaround I was able to come up with. It connects the shares in a proper way and have them securely and easy accessible in the home directory.

An SMB mount will not work if you do not have 'cifs-utils' installed. As often in Linux, when that is missing you will get very cryptic and misleading error messages, e.g. "Mount: wrong fs type, bad option, bad superblock on //myserver/sharename,..."

sudo apt install cifs-utils

For proper security, put in a password file in your home directory. It holds your SMB passwords in clear, so do not forget to secure the file (see below). Note that those depend on the share, they could be different from you login password of the Linux machine.

nano ~/.smbcredentials
  username=joe
  password=Doe711
  domain=myworkgroupname

Do not forget to secure the fily by making it inaccessible for any others than your own user:

chmod 400 ~/.smbcredentials

Now create the directories where the shares should appear (mount points)

mkdir ~./network
mkdir ~./network/myserver
mkdir ~./network/myserver/sharename

For each share add a line to the fstab file like this. I have not found a way around giving your user ID and group ID, at least I have not found one (I think its very inelegant as that info should go into the credentials file). Its a long line. Be careful with the spaces. Do not add any where are none.

sudo edit nano /etc/fstab
  //myserver/sharename /home/joe/network/myserver/sharename cifs credentials=/home/joe/.smbcredentials,uid=1000,gid=1000,iocharset=utf8,sec=ntlm, 0 0

Find the uid and gid with the command

id

Finally, let the system re-mount anything in the fstab file:

sudo mount -a

Now all network shares are accessible in the home directory in the folder "network". Its not as cool as browsing the network in Windows Explorer, but in fact its a lot faster :-)

Its not a real answer to the initial question, since the question asked for network browsing, but its the best usable alternative I have come across. I am going to mark this answer as "answered" in order to close the question. But I will be very happy when anyone in the future finds a way to make the network browsing function of the file managers accessible to all tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.