6

I have newly installed Xubuntu desktop on a computer. I need to work with files on a NAS store (using samba shares). Libre Office can not open them.

  • I browse the network in Thunar and see all files. The are recognised as Open Office files (right icon).
  • I can copy files to my desktop.
  • I can open the files with gedit.
  • On double click I see the Libre Office5 splash sceen then then nothing happens. I do not get any error message.
  • When I open Libre Office I can browse to the file with the open dialog but after file selection, I am just back to the blank file.
  • I can edit the file after copying it to my desktop.
  • After uncommemting X-GIO-NoFuse=true in the config file I do get an error when trying to open the file:

    General input/output error while accessing run/user/1000/gvfs/smb-share:server=, share=".

  • I have read about a bug to disable /use/share/applications/libroffice-calc.desktop and comment out x-KDE prototocls, but that did not help. The question is Can't open files through the network.

I did not try to mount the network share with fstab, since I need to be able to work with temporary shares in the file manager.

Anyone else having that problem? How can I solve that?

Using Xubunutu 16.04, amd64, kernel 4.4.0.-64-generic.

  • The bug mentioned in the answer you linked was supposedly solved long time ago. Do you have write permissions in the share? – user589808 Mar 17 '17 at 18:06
  • Indeed I saw the bug was for version 4 and I am using version5. I do have write permissions. Using gedit works fine on the same file. It seems to be just Libre Office. Do you have a network share to test if you can open a file on that with your current installation? – CatMan Mar 17 '17 at 18:23
  • Works fine (add to test it). It was a very small, half-page long, 22kb odt but size shouldn't matter. – user589808 Mar 17 '17 at 18:43
  • @CelticWarrior That's an important feedback, so it does not seem a general problem. Just to be sure: You were not using the command line. you used a file manager and connected a network share. You did not use a network share that was already connected via fstab file or such, right? Then you double clicked on a libre office file (size does not matter) and Libre Office did open that file on the network for edition on you local desktop? – CatMan Mar 17 '17 at 18:58
  • Exactly as you described. – user589808 Mar 17 '17 at 19:48
3

This error remains when I use the file managers network browsing function to access an open office file on a share. I still have no idea why it works with gedit and not with open office.

General input/output error while accessing
/run/user/1000/gvfs/smb-share..."** 

Since the question should not remain open indefinitely, I would like to put down the workaround that I found. With that also open office works fine.

The problem goes away when a share is not linked via gvfs as the file manager does it, but with cifs in /etc/fstab. The new entry maps the share to the home folder and uses a credentials file in the home folder

Here is how to do it, detailed explanations are in [How to select a file from a network share with file manager file open dialog.

sudo apt install cifs-utils
nano ~/.smbcredentials
  username=joe
  password=Doe711
  domain=myworkgroupname
chmod 400 ~/.smbcredentials
mkdir ~./network
mkdir ~./network/myserver
mkdir ~./network/myserver/sharename
sudo edit nano /etc/fstab
  //myserver/sharename /home/joe/network/myserver/sharename cifs credentials=/home/joe/.smbcredentials,uid=1000,gid=1000,iocharset=utf8,sec=ntlm, 0 0
sudo mount -a
3

"I had a similar problem on Ubuntu. Make sure the Libreoffice Gnome integration package is installed. In my case the package was libreoffice-gnome"

https://ask.libreoffice.org/en/question/9549/unable-to-open-files-from-windows-share/?sort=votes#sort-top

  • Wow, it worked! It was so simple.. I removed this package because looked useless in XFCE, but instead is still important for this feature. – Pisu Oct 18 '18 at 6:29
1

I had, and was able to solve, the same issue in Xubuntu. LibreOffice could not open the Samba share and showed:

general I/O error

Lubuntu on the same machine works fine.

My solution was to install PCmanFM and use it instead of Thunar.

Now I can dynamically open the share and libreoffice works like a dream. I hope I can help somebody with this tip.

  • Thanks for your comment. I had been trying Thunar and Nemo which both showed the given behaviour. I'll havea look a PCmanFM, but I'd rather stick to nemo. Maybe your input helps to understand the reason of that behaviour.. – CatMan Aug 15 '17 at 10:56
0

I had the same issue here with Linux Mint 18 (upgraded from 17.3) Cinnamon since I got version 5.4.3 of LibreOffice. I used to have a similar issue with previous versions of LibreOffice but there was a know workaround, which was to edit the libreoffice*.desktop files in /usr/share/applications and comment the line X-GIO-NoFuse=true. But since that last upgrade of LO it did not work any more.

However a few details and how I found a solution :

  • I use Cinnamon, so that means the file explorer is Nemo (version 3.0.6)
  • When opening a file over a samba share, the error only happened with LO Writer not with the other modules such as LO Calc !
  • Copying the file to the local hard disk, LO opened it smoothly.
  • When opening files using the command line, the error always happened, whether the module is LO Writer or another (LO Calc) !

I eventually noticed something : - that in /usr/share/applications, I now had two sets of libreoffice*.desktop files : one that followed the name syntax libreoffice-.desktop and one that followed the syntax libreoffice5.4-.desktop (and that actually were symlinks to files in opt/libreoffice5.4/share/xdg ). - I also noticed that when doing a right-click on the files, the top choice was 'Open with LibreOffice Writer' but that in the sub-menu 'Open with' there was 'LibreOffice 5.4' and that choosing this, it worked fine !

So I simply replaced the default software choice with 'LibreOffice 5.4' and I am now sorted out. Still it seems my installation is messy with components left from previous LO versions.

0

Here's what I found...

  • Working: Opening the same file in /run/user/... as view only with the --view option.
  • Working: Opening the same file smb://server/path/...
  • Working: Other fuse type mounts(Not things in /run/user/), I tried cryfs, I presume cifs works too.
  • Working: Every other program can read/write on /run/user/...
  • Not working: Opening the same file in /run/user/...
  • Not working: Opening the same file in /run/user/... with --nolockcheck
  • Not working: Tried opening other types of files(.txt, .xlsx) in /run/user/...

So it only happens on the /run/user/ mount and libreoffice in non-view mode.

I am using pcmanfm which seems to open everything in file///run/user/... instead of smb://... nautilus uses smb://.. to open files so that works.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.