1

I am using a wifi in an office.

At home, I have a VPN server running on a Synology DiskStation.

I can connect to my VPN server using its DynDNS-adress and a PPTP connection I configured in the network manager of my laptop. After connecting my laptop still has the IP 192.168.10.27.

The disk station is reachable on http://10.0.0.0:port (e.g. the webpage of the administration website) and according to the VPN server logs the laptop then gets another IP 10.0.0.1. This is what I expected. I am a bit confused that the network manager shows under active connections two entries, one for the wifi and one for the VPN, and both have the same IP 192.168.10.27.

Now, no internet is working. If I ping 8.8.8.8 the ping gets lost. Also, if I ping my router on the home network, this ping gets lost.

There is a setting on the VPN server to use a specific IP as DNS server. I checked this and put in my home router's IP. This should make the VPN-server use the home router for resolving names.

Also, what I did was putting a route in the network manager. To my understanding I have to tell the VPN that all internet connections should be managed by my home router. So, I put in 192.168.0.1 as additional DNS server and created a route with this as address, 255.255.255.0 as netmask and 10.0.0.0 as gateway. (I took that out as it was not working.)

After I connected I was able to load a webpage, but then after some seconds the internet connection was lost again.

Where am I wrong?

After connecting ifconfig shows an added item:

ppp0      Link encap:Punkt-zu-Punkt-Verbindung  

  inet Adresse:10.0.0.1  P-z-P:10.0.0.0  Maske:255.255.255.255
  UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1400  Metrik:1
  RX-Pakete:7 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
  TX-Pakete:7 Fehler:0 Verloren:0 Überläufe:0 Träger:0
  Kollisionen:0 Sendewarteschlangenlänge:3 
  RX-Bytes:88 (88.0 B)  TX-Bytes:106 (106.0 B)


ben@acer:~$ ip r s
default dev ppp0  proto static 
10.0.0.0 dev ppp0  proto kernel  scope link  src 10.0.0.1 
95.91.0.108 via 192.168.1.1 dev wlan0  proto static 
95.91.0.108 via 192.168.1.1 dev wlan0  src 192.168.10.27 
192.168.0.0/20 dev wlan0  proto kernel  scope link  src 192.168.10.27  metric 9 

ben@acer:~$ route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
10.0.0.0        0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
95.91.0.108     192.168.1.1     255.255.255.255 UGH   0      0        0 wlan0
95.91.0.108     192.168.1.1     255.255.255.255 UGH   0      0        0 wlan0
192.168.0.0     0.0.0.0         255.255.240.0   U     9      0        0 wlan0

I like that 10.0.0.0 seems to be the default route but I am not sure if there should be a gateway somewhere in it. In my case that gateway should probably be the router on my home network with the IP 192.168.0.1. Is this information missing in the routing table?

  • Before I connect, if I run ifconfig, I see my network adapter's local IP address and the loopback one (lo). After I connect to the VPN, I still see those in ifconfig, but I also see a tun0 connection with a new IP address. Are you seeing that kind of behavior? – Organic Marble Mar 17 '17 at 1:02
  • Yes, that output looks like what I'd expect to see. Since I only know OpenVPN, trying to think how to troubleshoot. In my setup the server pushes the route and DNS server addresses to the client. Sounds like you are specifying them on the client side, which seems OK. – Organic Marble Mar 17 '17 at 1:17
  • Actually, I am not sure about the DNS. The Synology VPN Server may not have/be a DNS Server - I read about people having had that problem. But they solved it by giving a certain IP to the VPN Server that works as a DNS. In my case I tried giving my home routers IP 192.168.0.1 and I also tried with 8.8.8.8. but with no success. I will update the routes to the question. As I understand routing I should put the default route to 10.0.0.0 which I guess is the case. – Ben Mar 17 '17 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.