I'm trying to use my MacBook to Remote Desktop connect to my Ubuntu server. I am able to ssh, but I can't seem to figure out how to Remote Desktop connect.

Any suggestions? Also my Ubuntu workstation is 1200 miles away so I can't physically access it but I can access it through ssh so hopefully I can configure what I need through ssh.

I tried the instructions in the first answer on here, but when I tried to RDP from a windows PC, ti stated that: Remote Desktop can't connect to the remote computer for one of these reasons:

  1. Remote access to the server is not enabled
  2. The remote computer is turned off
  3. The remote computer is not available on the network

It shouldn't be #2 and 3 since I can ssh to the server just fine. So I suspect #1 is the culprit.

  • For RDP you need a desktop. If you have one installed then installing and configuring xrdp should be as in your linked answer.
    – user589808
    Commented Mar 17, 2017 at 0:22
  • You can't RDP from a macbook/laptop?
    – David
    Commented Mar 17, 2017 at 0:37
  • ALso, I did try from a desktop and received the error above.
    – David
    Commented Mar 17, 2017 at 0:37
  • 1
    David - when @CelticWarrior says "you need a desktop", he doesn't mean a laptop wont work. He means you need a gui installed on your Ubuntu server. If you have a basic server from the "server" download link on ubuntu.com, it won't have a gui (aka a desktop) unless you added and configured one (i.e. Unity, Gnome, etc.). Without a desktop/gui, something like xrdp will not work.
    – James
    Commented Mar 17, 2017 at 0:47
  • James: Ah I see. So in the link in the OP, I followed those instructions and installed xRDP and xfce4. Aren't these all that is needed to set up the "desktop?"
    – David
    Commented Mar 17, 2017 at 1:05

5 Answers 5


You can use Microsoft Remote Desktop from App Store. Set up your Ubuntu this way:

From DigitalOcean community page.

sudo apt-get update

If you don't have desktop installed:

sudo apt-get install ubuntu-desktop

After that install XRDP:

sudo apt-get install xrdp

Enable XRDP to start on boot:

sudo systemctl enable xrdp

If you have a firewall make sure that the 3389 port is open:

sudo ufw allow 3389/tcp

Now connect with Microsoft Remote desktop to your Linux machine.

  • did this works but the session is like taking 20-30 seconds a click.
    – AhmFM
    Commented May 25, 2023 at 19:45
  • I have to do this settings as well askubuntu.com/a/1466974 for taskbar and desktop to be visible properly also you can't login from ubuntu from other places need to log out else blank screen will be shown. Commented Nov 20, 2023 at 1:04

I successfully logged-in remotely from my iMac macOS Mojave desktop into my hackintosh, which is a retrofitted 2012 Apple Macbook Pro running smoothly Ubuntu 16.04:

From the Ubuntu Desktop in 16.04

  1. Download and install vino by running sudo apt-get install vino within the Ubuntu terminal.
  2. Next run vino-preferences.
  3. After the vino application preferences window prompts, ensure that the "Allow other users to view your desktop" and "Allow other users to control your desktop" options are selected beneath the "Sharing" field; it is also recommended to select the "You must confirm each access to the this machine" and "Require the user to enter system-password".
  4. Run sudo-reboot and then log-in to the Ubuntu 16.04 desktop.
  5. Retrieve and the device-IP address by running ifconfig -a; the local-IP address of the device will be returned within the terminal-output under the field: "inet addr:" (e.g. inet addr: After noting the local-IP address of the device, proceed with the next set of instructions from your macOS desktop.

From Ubuntu 18.04-2 LTS

  1. Evidently, vino functionality was merged in Ubuntu 18.04.2 LTS Gnome Control Center, so it's much easier- simply go to "Settings".
  2. Within "Settings", scroll down to the "Sharing" tab within the left-hand side of the window.
  3. Turn on "Screen Sharing"- select "Allow connections to control the screen" and "Require a password" underneath "Access Options" then proceed with the below instructions to remotely access your Ubuntu 18.04.2 LTS desktop from your macOS desktop.

Logging-in From macOS Mojave

  1. Access the "Spotlight" by hitting CMD + Space-bar
  2. Within the Spotlight field, enter vnc://your_server_ip:5900 (e.g. vnc://
  3. If successful, the Screen Sharing application should automatically launch within your macOS desktop to remotely view your Ubuntu 16.04 or Ubuntu 18.04.2-LTS device on your local-network as depicted by the screen-shot below- enjoy!

enter image description here

  • 1
    You might need to do this on Ubuntu 20.0.4 askubuntu.com/a/1120075/915134
    – unify
    Commented May 17, 2020 at 22:00
  • 1
    Note: if you're on a K-based desktop (rather than Gnome) you can use krfd instead of vino - comes with fewer dependencies for K. Commented Jan 15, 2022 at 12:48

You need to enable Remote Desktop Connection on your Ubuntu machine. You can do

To enable Remote Desktop Connection on a host computer from terminal you should do the following (assumign the host is an Ubuntu):

  1. Connect to the host with X forwarding, ssh -Y username@host where username and host are the ones you use to connect to your host.
  2. Enable remote desktop sharing
  3. set the authentication method to vnc
  4. Restart lightdm
export DISPLAY=:0
dconf write /org/gnome/desktop/remote-access/enabled true
dconf write /org/gnome/desktop/remote-access/prompt-enabled false
dconf write /org/gnome/desktop/remote-access/authentication-methods "['vnc']"
dconf write /org/gnome/desktop/remote-access/require-encryption false
sudo service lightdm restart

And then try conecting to it via Remote desktop.

Let me know how it goes and if any problem arises, I can refine the answer to your need.


i found some of these answers overly complicated.

in ubuntu, enable sharing on the network. Settings / Sharing / Screen Sharing https://www.howtogeek.com/429190/how-to-set-up-remote-desktop-on-ubuntu/

on the mac, use VNC Viewer.


make a connection in VNCViewer from the mac to the ubuntu box.

  • This will not enable Remote Desktop on the server, which is the OP problem. Commented Feb 19, 2021 at 8:10
  • 1
    the steps in that reference is what i did precisely and after doing those steps, Remote Desktop was enabled on the server and i used it from the Mac. that means either it was enabled on my system, by default (brand new generic Ubuntu install), or the steps i followed enabled it. since the Sharing was disabled (grayed out) until i followed the reference, i'd assume the latter. maybe things are just different in Ubuntu since the original post. my primary reason for leaving this comment is for people in the present (and possibly future), as it worked and was straightforward. Commented Feb 20, 2021 at 13:51

Not an answer (no SSH, but might be helpful still)

In Ubuntu 23.10:

  1. On Ubuntu > Settings > Sharing > Remote Desktop > Setup.
  2. On Mac > App Store > Download "Microsoft Remote Desktop", add hostname + user from Ubuntu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .