3

Ok. I am going to go insane if I cannot figure this out.

I work on a virtual server running Ubuntu 12.04, which I need to upgrade to 14.04. That part goes just fine. However, upon upgrading, I discovered that my server doesn't want to play nicely with OCSP anymore. Apparently Apache is changing to OCSP stapling in version 2.4, which is forcibly bundled with the OS upgrade. If I thought I could figure out OCSP stapling in a timely fashion, great. But the way I see it, I could downgrade Apache back to 2.2.22 as OCSP is unfamiliar to me at this point. I am a new SYSADMIN on the system I work on, and had little to no turnover. I am also far more familiar with RedHat than Ubuntu.

I have been doing all of my testing on a clone because I cannot bring the primary down for as long as I (apparently) needed to for testing. I have successfully installed Apache 2.2.22, but I still can't get it to work. I get a variety of errors. Apache won't restart because of abc, and once I figure those out, or mitigate them, a whole new host of errors shows up.

I am happy to provide specifics if needed, but even general advice would be fantastic.

  • 1
    For general advice, one alternative is to know that 12.04 is good until April 28, 2017, so you have a little over a month to learn OCSP stapling so that you can upgrade in the normal way. Installing 2.2.22 on 14.04 is probably a bad idea because you have to do something ugly like compiling from source, which avoids all the nice benefits of the package manager (easy security updates being quite important to a web server). – Chai T. Rex Mar 16 '17 at 23:53
  • I completely agree. It turns out one of the things giving me a hard time was a module that is no longer supported, and no longer necessary as Ubuntu and apache natively support OCSP in these new versions. – Larka16 Apr 20 '17 at 18:11
0

apt-mark hold

This will hold back a package even in an OS upgrade. So I am left with Ubuntu 14.04, running Apache 2.2.22. Turns out I have to update it anyway, but this made my life easier to hit the EOL deadline, while I work on successfully updating apache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.