25

I just installed 16.04 on my MacBook Air, and everything seems to work well, except booting the system. I've been going through the dmesg-log and found out that drm_kms_helper-errors occur repeatedly and takes a lot of time each. The excact error is like this:

[drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:26:pipe A] flip_done timed out

The CRTC-value and the pipe-value varies, but otherwise all the errors are identical.

What does this mean and how do I fix it? If it can't be fixed, how do I prevent it from using so much time when booting?

38

This is a bug. To avoid delay you can use workaround. From terminal run:

  1. sudo nano /etc/default/grub

Then add the kernel boot parameter: video=SVIDEO-1:d, so it will look like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

  1. sudo update-grub
  2. sudo reboot
  • didn't work for me :( – lucacerone Feb 5 '18 at 8:25
  • Works very well on Macbook with ElementaryOS too :) – user17254 Feb 9 '18 at 13:41
  • 3
    with this boot parameter the boot time improved from about 3 Minutes to 20 seconds (ubuntu 18.04) with a Intel GM965 graphic – sdu May 21 '18 at 14:38
  • Fixed issue on Arch Linux on Lenovo ThinkPad R61i. – Erikas Jul 11 '18 at 18:18
  • It work on my old Intel Pentium Dual-core 32bit, lubuntu 16 – LeCanardNoir Aug 21 '18 at 18:51
4

I have still this problem after adding video=SVIDEO-1:d to grub like described above.

But I found this entry (https://bugs.archlinux.org/task/51703) with this comment:

Comment by Luis Bourgard (unnilquadium) - Friday, 26 January 2018, 19:08 GMT Still present in 4.14.14 It only happens with the xf86-video-intel package installed (running on a laptop with intel integrated graphics on an i5-2410m). Uninstalling that package fixes the issue, but it also introduces some screen tearing.

I removed the package with sudo apt-get remove xserver-xorg-video-intel. Maybe this works for us.

For screen-tearing correction, these ideas may also help (https://bbs.archlinux.org/viewtopic.php?id=233957):

Post by jaylittle - 2018-06-25 21:54:22 If you want to solve your screen tearing issue in Xfce without relying upon the broken intel xorg driver, just disable the built in Xfce compositor and run something like compton as part of your session startup. That should resolve your issue with screen tearing and allow you to use the more reputable kms driver.

  • 2
    Exactly! Removing xf86-video-intel fixed the issue. This package is recommended to avoid everywhere! – Erikas Jul 11 '18 at 17:56
  • Don't working on my old intel pentium dual-core 32bit with lubuntu 16 – LeCanardNoir Aug 21 '18 at 15:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.