2

I run the kubuntu 16.10 with all latest updates, kernel 4.8.0-38 x86_64 and I'm experiencing this problem:

The system used to work with all my USB flash drives perfectly and now it suddenly stopped. No USB drive is recognized or mounted. Here is my research:

  • The flash drives are OK since they work fine on other computers.
  • USB ports are OK. Other devices like USB keyboard or USB mouse work flawlessly in all USB ports.
  • If I boot the kubuntu live CD (16.10) then the very same USB drives on the very same computer are recognized withouth any problem.
  • I have another 2 computers with kubuntu 16.10 with the same updates and all the USB drives work fine there.
  • The system knows about the USB drive being inserted into the USB port, because:
    • the device is correctly listed in the lsusb list
    • a message appears in dmesg and it says that new usb device being connected. But there is no info about /dev/sdx being assigned to it.

So the device is connected, but because it has no /dev/sdx it is not accessbale for fdisk or mount.

Also the sound output stopped working for no reason and it works fine in live-CD, but I don't know whether there is any relaion between this two issues.

Any ideas? Thanks in advance.

EDIT:

# tail -f /var/log/syslog


kernel: [80138.724578] usb 2-1.5: new high-speed USB device number 15 using ehci-pci
kernel: [80138.838130] usb 2-1.5: New USB device found, idVendor=0930, idProduct=6545
kernel: [80138.838133] usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
kernel: [80138.838135] usb 2-1.5: Product: USB Flash Memory
kernel: [80138.838137] usb 2-1.5: Manufacturer:         
kernel: [80138.838139] usb 2-1.5: SerialNumber: 6C626DBED999ED607000235D
mtp-probe: checking bus 2, device 15: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5"
mtp-probe: bus: 2, device: 15 was not an MTP device
1
  • could you provide the output from sudo tail -f /var/log/syslog when you insert the USB-drive? – mgor Mar 16 '17 at 18:45
1

Finally I found the answer by myself.

The problem was that my /boot partion ran out ouf space, then a kernel update arrived, but because of 0 bytes left on /boot the kernel package did not install completely (I guess some modules were missing) and after next reboot the new (incomplete) kernel was loaded. The system worked quite good, but some parts did not, e.g. the mentioned USB drives and sound output.

The solution was just in removing all the obsolete kernel packages which are stacking in my system, finishing the installation of the newest kernel and a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.