2

My firefox refuses to launch even after a clean re-install. This happens with the taskbar shortcut as well as when launching through terminal sensible-browser.

It just gives me this Mozilla Crash Reporter Terminal Error alongside Crash Reporter

Any ideas?

PS Ubuntu is running on Raspberry Pi 3 and was confirmed working a few days ago

  • 1
    Try removing/backing up ~/.mozilla/ so you get a fresh new profile: mv ~/.mozilla ~/mozilla.backup. Also, would be interesting to see the output when you try starting firefox from a terminal emulator. – mgor Mar 16 '17 at 19:06
  • Here's the output: image.prntscr.com/image/1caaca07e7c44214ba61d6ab568a9290.png – BlaDrzz Mar 18 '17 at 21:15
  • And did you try with a fresh clean profile? – mgor Mar 20 '17 at 11:05
  • What do you mean a fresh clean profile? I never logged into it. – BlaDrzz Mar 20 '17 at 14:18
  • In your question you say "after a clean install", is that of the os or Firefox? If you just reinstalled Firefox, your user will still have a profile in ~/.mozilla/firefox which might contain an add-on or setting that is causing it to crash. Re-read my first comment. – mgor Mar 20 '17 at 14:22
0

Firefox 57 still doesn't work!!

From Firefox 55 through to 57, the same trouble continues, so this question is still valid. This issue only applies to Raspberry Pi running Ubuntu.

For those who need a working version and got as frustrated as I did, here is a workaround. There does not seem to be any way to fix this issue, except by downgrading Firefox.

You can use Synaptic to force an old version of Firefox, by selecting the Firefox package, then go to Package on the top bar, click Force version and click apply. Afterwards you must lock the package by going to Package and selecting Lock version. Note that you will only be offered Firefox 45.0.2.

You can also use apt from the terminal with something like:

sudo apt-get install firefox=45.0.2+build1-0ubuntu1 (You can install other versions like this, you just have to get the build name exacly right)

Lock the version with

sudo apt-mark hold firefox

Alternatively, you could download the version you want from here and install it manually. Firefox automatically installs new versions, so you will have to disable this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.