1

I have run: steam (after installing it from the official Trusty repos) and while the download updater window pops up, after this updater is finished with the download it gives the error:

rm: cannot remove ‘/home/fusion809/.steam/steam’: Is a directory
rm: cannot remove ‘/home/fusion809/.steam/bin’: Is a directory
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
[2017-03-16 20:11:21] Startup - updater built Mar 13 2017 20:55:20
Installing breakpad exception handler for appid(steam)/version(1489442219)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

Is there a package I'm missing (that for some reason was not installed when I ran: sudo apt-get install steam to install Steam), or?

Oh and I have tried following this answer, namely running:

cd $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak
cd $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak

and then tried re-launching Steam. This did not fix this error. Also in accordance with this answer I've added to near the start of $HOME/.steam/steam.sh:

export LD_PRELOAD='/usr/$LIB/libstdc++.so.6'
export DISPLAY=:0

and that didn't fix it. In fact it introduced further errors likely due to the fact that ' causes the $LIB variable not to be expanded. Plus running echo $LIB in a terminal returns /usr/lib so I think what was intended in that answer was:

export LD_PRELOAD="$LIB/libstdc++.so.6"
export DISPLAY=:0

but that also did not fix, or even alter the error in a positive way (as /usr/lib/libstdc++.so.6 does not exist on my Ubuntu 14.04 installation, /usr/lib/i386-linux-gnu/libstdc++.so.6 and /usr/lib/x86_64-linux-gnu/libstdc++.so.6 do exist, however). Setting LD_PRELOAD to either of these paths does not fix the error either, merely adds lines of:

ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libstdc++.so.6' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

or:

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libstdc++.so.6' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

to the error message. To try and help you help me I have also run:

LD_DEBUG=libs steam > steam_debug.log 2>&1

and this is the steam_debug.log I got.

  • Didn't think it was relevant, but I've already tried that. Besides deleting it again only causes it to re-run the Steam updater (downloading all that data [which is 340 MB, btw] again), rofl. – BH2017 Mar 16 '17 at 11:15
  • Sure does, mate. I thought of deleting that folder as soon as I saw that part of the error message, don't worry you're not the only one to notice that error. – BH2017 Mar 16 '17 at 11:16
  • What if you run steam.real? – muru Mar 16 '17 at 11:21
  • Just ran it (hasn't finished yet, I'll let ya know when it does) and it's re-downloading the 340 MB update. – BH2017 Mar 16 '17 at 11:22
  • From the command-line I got the error: [2017-03-16 21:24:37] uninstalled manifest found in /home/fusion809/.steam/steam/package/steam_client_ubuntu12 (1). [2017-03-16 21:24:37] Error: Failed to load package manifest. and a window pops up with the error: Fatal Error: failed to load libsteam.so. – BH2017 Mar 16 '17 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.