I recently bought an Aspire-V5-591G.I installed ubuntu 16.04 alongside windows 10.I was not experiencing any problem with my internet connection on windows. On ubuntu i have never managed to connect by ethernet or wifi, except from my phone's wifi hotspot.Somehow i could connect to that. I tried many solutions,but i ended up blocking the hotspot wifi as well. Can someone guide me in order to solve the problem?

This is what i have already tried:

1)Link 1 then Link 2

2)Link 3

After updating my ubuntu version, I established an ethernet connection.I can connect to the internet.Yet the wifi connection doesnt work again.

output: lspci -knn | grep Net -A3

07:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac >Wireless Network Adapter [168c:003e] (rev 32) Subsystem: Lite-On Communications Inc QCA6174 802.11ac Wireless Network >Adapter [11ad:0807] Kernel driver in use: ath10k_pci Kernel modules: ath10k_pci

08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. >RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev >15)

output iwconfig:

lo no wireless extensions.

enp8s0 no wireless extensions.

wlp7s0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on

    rfkill list
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: acer-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Mar 16 '17 at 17:36
  • Please please please do not post pictures of text! Just copy/paste the text if possible into your answer. It makes everyone's life infinitely easier. (case in point, output of Pilot6's command) – Kaz Wolfe Mar 16 '17 at 18:06
  • I ll keep that in mind.thanks. – Hikachi Mar 16 '17 at 18:12
  • OK. Then post the output of rfkill list. Please use the {} button for formatting. – Pilot6 Mar 16 '17 at 18:47
  • I executed the command rfkill list while i was connected to the ethernet..If you want me to go offline first,then execute, tell me.. – Hikachi Mar 17 '17 at 10:49

Well, my only suggestion is to start over from scratch.

At the top of the screen you will either see two arrow pointing in different directions, or an icon that looks like a pie slice. Right click on that to expose the menu.

At the bottom of the menu click on 'Edit Connections'. You should get a dialog box right in the middle that lists all connections. Click on each one individually and then click on 'Delete'.

Once all the connections have been deleted, in the same dialog box click on 'Add'. You will presented with another dialog box that has a line item 'Ethernet'. Click on 'Create'.

You will then be presented with another dialog box with multiple tabs. Click on the tab that says IPv4 Settings. It will then display a dialog that should say 'Automatic DHCP'. If it does not then use the drop down to set it and then click on 'Save'.

Reboot the OS and see if you have connectivity.

This is my only suggestion since I am not that familiar with networks. If you have a weird network card then a driver might be the problem, but other than that I have no suggestions.

Good luck.

Run in a terminal

sudo tee /etc/modprobe.d/blacklist-acer.conf <<< "blacklist acer_wmi"

and reboot. This will blacklist the acer_wmi module that is blocking your Wi-Fi.

  • It did not work. :S – Hikachi Mar 18 '17 at 21:58
  • I fixed a typo in the command. Try again. – Pilot6 Mar 19 '17 at 8:34

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.