0

I have installed ubuntu 16.04 but I am not getting wifi option in the menu bar.
I have installed Broadcom 802.11 additional drivers but it made no difference.

What should I do ?

  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Mar 16 '17 at 9:14
  • Most likely you need to disable Secure Boot in BIOS. – Pilot6 Mar 16 '17 at 23:17
0

I guess you might have missed to disable the secure boot option. Reinstall the bcmwl-kernel-source package.

$sudo apt-get install --reinstall bcmwl-kernel-source

And the focus on setting the password for disabling secure BOOT.

You then need to restart your system, and press any key to enter into the configuration mode. This screen will only be there for few seconds, so keep your focus while restarting.

You then need to toggle the secure boot option to disable and it will ask for the password you set will installing bcmwl-kernel-source package. It will not directly ask for the password, but ask only certain characters of your password,

For e.g.: Enter Character 2, Enter Character 5, etc.

After that confirmation, the system will boot normally and WiFi drivers should be loaded on your Ubuntu.!

Happy Networking!

| improve this answer | |
-1

Had the same problem with my old HP laptop with old broadcom drivers which might not be supported

Installing B43 and B43legacy drivers from http://linuxwireless.org/en/users/Drivers/b43/ seemed to do the trick for me.

Assuming your model is in their list, just enter in the following command to install and then reboot after.

sudo apt-get install firmware-b43-installer

Note the wifi interface after will be called wls1.

NOTE: There are other driver sets there with install instructions on the site if these aren't your type.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.