0

I am working on a 7 year old laptop with Ubuntu 10.10, i.e Maverick. It's 32-bit. While the ubuntu boots up with some issues, particularly with the error of the BIOS clock, whose battery has died some time ago. While I press 'I' to ignore the error, bootup normally and go use ubuntu normally, I am unable to get into recovery mode as I need to change the sudo password.

Whenever I try to go into recovery mode it doesn't even load the menu options, all it does is loop endlessly something like this line: " Loading disk fsck: ... done" (not precisely this line but something like that) .

Also this is ubuntu was modified by some company for their own purposes, so I'm pretty sure they must have tried to disable the ubuntu recovery mode option. I just need help to confirm that.

I've tried to use boot-repair to fix Grub, but it didn't work and I still can't get into recovery mode.

Lemme know If there's any more detail I can add for understanding this issue.

Here's the boot-repair report file

0

Boot Ubuntu live from a a flash drive and choose try Ubuntu without installing. Once inside open up a terminal and run sudo fdisk -l and find where Linux is installed (/dev/sda*) - * could be any number

Next create a directory in your media folder corresponding to where Linux is installed whether it's sda1,sda2,sda3....etc. by running the following command

sudo mkdir /media/sda*

(* being the number for the partition)

Then mount the hard drive to that folder by running:

sudo mount /dev/sda* /media/sda* 

(again keep in mind the asterisk indicates where Linux is installed)

Once mounted run sudo chroot /media/sda*

Then finally passwd geek

You should be able to change your password now.

  • Thanks a lot. I didn't know that you can change ubuntu password without going to the terminal window from ubuntu recovery mode. – Bhaskar Mar 18 '17 at 6:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.