I'm trying to install Ubuntu 16 on my Acer Travelmate that came with a pre-installed Windows 10.

I installed Ubuntu from an USB device along with Windows 10. The installation was successful, but Windows 10 keeps booting every time.

I followed some instructions I came accross and I ensured that:

  • UEFI is enabled
  • Secure Boot is disabled
  • the Fast Startup option in Windows 10 is disabled
  • the boot sequence is in the right order

No matter in which order I boot the hard drives in, it will always result in booting Windows and not showing the boot menu.

Also, I used Boot-Repair to fix this problem. It didn't help but gave me some (hopefully) useful information: https://paste2.org/9XxVEENE

What could I try next?

  • Booting the Ubuntu installation in UEFI mode should do the trick. For that you will have to add a new boot entry for your flash drive where Ubuntu is installed. Find the option to add a new boot entry , select your USB flash drive and navigate to EFI>Boot>bootx64.efi then press enter and give the new boot entry any name and make sure to add the boot entry to the top of the boot priority list and finally reboot and continue with the installation.
    – Ahmed K.
    Mar 16, 2017 at 12:07

1 Answer 1


Have you found the "Select an UEFI file as trusted for executing" option? For me it's invisible, but some other people confirmed, that sometimes it solves the problem. Allowing boot of Ubuntu on a Acer Aspire v5-531 with UEFI

  • That was the solution. But instead of the bootx64.efi file I had to select the grubx64.efi file in order to get it working. I enabled the UEFI and Secure Boot options, selected the grubx64.efi under "Select an UEFI file as trusted for executing" and put the "EFI File Boot" option in the first place of the boot priority list.
    – MrSparkle
    Mar 17, 2017 at 10:20

Not the answer you're looking for? Browse other questions tagged .