5

I'm trying to dual-boot ubuntu with windows. Below a detailed description of all I have done. Skip to 2nd last paragraph if you don't want to read it, pretty basic setup.

I've got windows 10 already installed and there's 70gb free for Ubuntu. I've downloaded the file ubuntu-16.04.2-desktop-amd64.iso today (Ubuntu 16.04.2 64-bit Desktop edition). Using a program called "Rufus" I've put this file on a usb stick using the option "ISO image", creating a UEFI Bootable USB Drive. I've successfully booted this USB drive with the Ubuntu installation.

In the menu when booting the USB drive I choose "Install Ubuntu" and choose English. When it's asking for updates while installing and to install hardware, I've tried both to no success. In the next screen I did both the option "Install Ubuntu alongside Windows" as well as "something else". When choosing something else I did 8GB swap and 62GB EXT4 Journaling File System with mount point /, both have are primary and beginning of this space:

enter image description here

So used pretty much all combinations.

Next I set English language and keyboard, fill in my name and password, set to log in automatically. It will slowly install from there on, but quits halfway with the following error message:

Error installing /target/var/cache/apt/archives/snapd_2.23.1_amd64.deb: 
trying to overwrite '/etc/apparmor.d/usr.lib.snapd.snapconfine', which is also in package snap-confine 2.23.1

And after pressing ok:

enter image description here

Pressing OK on this last error, it says the installation is complete, but if I leave the usb out windows will boot and I don't see the GRUB boot loader.

What I've read on the internet is that this may be caused by 2 packages called snap and snapd, which can't co-exist. How do I solve this for the installation process?

  • From windows, open an admin command prompt and run bcdedit. Could you please edit the question to include its output? – rlee827 Mar 16 '17 at 0:06
  • 1
    Just unplug your ethernet / internet connection. See my answer below. – sabalaba Mar 16 '17 at 0:22
  • @rlee827, why would anything on windows influence an Ubuntu packaging bug? – sarnold Mar 16 '17 at 3:07
7

Solution: Unplug your internet connection / disable wifi.

Quick fix is to have no active connection during installation.

This is a known bug that is being caused by a package that is downloaded using aptitude. (See link below.) To make sure you don't download the package, unplug the ethernet cable or disable wifi before beginning installation.

See bug report: https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1673247.

  • Can confirm. This worked for me. – Adam Carr Mar 16 '17 at 0:22
  • This works indeed! Tried it last night and got it working :) – Exclu Mar 16 '17 at 14:49

protected by Community Mar 16 '17 at 0:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.