8

First of all im sorry if this thread is duplicated with another one, but i didnt find a solution for the problem.

So i bought new laptop (Lenovo Y520) and setup dual boot Win10 with Ubuntu 16.04 and wireless doesnt work for the ubuntu (LAN works).

ifconfig

enp4s0    Link encap:Ethernet  HWaddr c8:5b:76:da:32:ba  
      inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::62bc:4b27:ec0f:1d9c/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:18584 errors:0 dropped:0 overruns:0 frame:0
      TX packets:12706 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:20071392 (20.0 MB)  TX bytes:1500456 (1.5 MB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:1849 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1849 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:200236 (200.2 KB)  TX bytes:200236 (200.2 KB)

.

iwconfig

wlp3s0    IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on

enp4s0    no wireless extensions.

lo        no wireless extensions.

I ran some commands which found in another threads.

sudo lshw -class network


*-network               
   description: Wireless interface
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 78
   serial: 00:28:f8:69:15:13
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.8.14-040814-generic firmware=22.361476.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
   resources: irq:332 memory:a4200000-a4201fff
*-network
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: enp4s0
   version: 10
   serial: c8:5b:76:da:32:ba
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.0.102 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:322 ioport:4000(size=256) memory:a4104000-a4104fff memory:a4100000-a4103fff

.

rfkill list

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: yes
2: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

.

lspci -nnk | grep 0280 -A2

03:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)
Subsystem: Intel Corporation Device [8086:1010]
Kernel driver in use: iwlwifi

Things that i've tested and didnt worked.

* sudo rfkill unblock wifi
* Additional Drivers -> Not showing wifi driver
* restart network-manager service
* http://askubuntu.com/a/859263
17

Run in a terminal

sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"

and reboot. This should unblock your Wi-Fi.

  • 1
    Thank you thank you thank you thank you thank you from the bottom of my heart Pilot 6. I asked my company to switch to Linux and got a top of the line Lenovo Legion Y920 after successfully testing a live install on an Alienware 17 that had the same Killer 1535 network card. So naturally I was completely devastated when I installed 16.04 on my shiny new Lenovo and had no wifi access. I was at my wits end since I'm still a bit of a newb and I was going to have to return it and go back to MacOS because I leave for vacation and wouldn't have time inside the return window to debug the wifi. – anon58192932 Aug 29 '17 at 6:44
  • 1
    You win the Internet today, sir! – ivan_bilan Nov 21 '18 at 18:15
  • Thank you so much! I spent so many hours on this!!!! Also unblocked my bluetooth! – Ofek Gila Apr 5 '19 at 7:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.