14

There is no one guide that I have tried that results in a fully working WebEx on Linux. Typically audio is the feature hardest to get working. How do I get WebEx working with audio on Ubuntu?

8

Another and probably the simplest way is to use a dedicated Cisco Webex app for chrome. I have just tested it on Ubuntu 16.04 with Chrome version 60.3 and everything but screen sharing (which is not available) works perfectly well.

Please, keep in mind that this is a Chrome based application, not a browser plugin. You'll need to open that application and use it instead of pasting the URL directly to Chrome.

mid 2018 Update: webex with screen sharing works perfectly fine on Ubuntu 16/18 on latest Chrome and Firefox using dedicated plugin for screen sharing

early 2018 Update: Website app has been updated. Now it's possible to connect easily with all versions of webex so dedicated webex app is not really usefull anymore. Screen sharing on Ubuntu is still not possible though. Tested with chrome.

  • Thanks for this +1. In my case screen sharing is essential so hope they add that feature soon. – mcarans Aug 23 '17 at 19:54
  • 5
    "This app is only for attendees who are joining WebEx meetings that use Cisco WebEx Meeting Center version WBS30 or later." Oh lawd, kill me now... better yet, kill webex – Damien Roche Feb 27 '18 at 16:39
  • Screen sharing still doesn't work for WebEx personal rooms – mcarans Oct 3 '18 at 10:40
  • If you want to screen share with a personal room, the answer below (askubuntu.com/a/893216/558070) works. – mcarans Oct 3 '18 at 11:33
  • WebEx have fixed the personal room issue – mcarans Jan 31 at 10:07
7

2019 update: WebEx through Chrome on Ubuntu works fine for me with screen sharing (even in personal rooms) and the ability to start meetings. You should use the url with "meet" in it not "join" for personal rooms eg. abc.webex.com/meet/xxx

The steps below may not work anymore.

The following steps should work (tested on Mint 18 based on Ubuntu 16.04 and Mint 19 based on Ubuntu 18.04):

  1. Remove 64 bit Firefox if installed:

    sudo apt-get remove firefox
    
  2. Install 32 bit Firefox 52 (or earlier version). Go to download and extract the 32-bit Firefox ESR installer. Make sure it doesn't auto update by changing the update settings in preferences.

  3. For Firefox 52: Launch Firefox and type about:config in the location bar.

  4. For Firefox 52: Accept the risks and then add a key (right click mouse → New → Boolean)

  5. For Firefox 52: Call the key plugin.load_flash_only and set it to false

  6. For Firefox 52: Add a Firefox extension for switching the user agent e. g. User-Agent Switcher or edit the general.useragent.override string property.

  7. For Firefox 52: Set the user agent to an earlier version of Firefox on Linux e. g.

    Mozilla/5.0 (X11; Linux i586; rv:31.0) Gecko/20100101 Firefox/31.0
    
  8. Close Firefox

  9. Download the .tar.gz 32-bit JRE package for Linux on www.java.com and store the file in the folder Downloads in your home folder (i. e. ~/Downloads). It will be of the form: jre-8u161-linux-i586.tar.gz.

  10. Then do the following to extract the JRE in a shell:

    sudo mkdir -p -v /opt/java/32
    cd ~/Downloads
    tar -zxvf jre-8u161-linux-i586.tar.gz
    sudo mv -v jre1.8.0_* /opt/java/32
    
  11. Now the Java needs to be linked to Firefox. In a shell:

    mkdir -p ~/.mozilla/plugins/
    cd /opt/java/32/jre1.8.0_161
    ln -sf $PWD/lib/i386/libnpjp2.so ~/.mozilla/plugins/
    
  12. Launch Firefox and WebEx should now work.

  13. If it doesn't work and the wrong Java plugin appears to be loaded e. g. IcedTea, then remove them in a shell:

    sudo apt-get remove icedtea-plugin icedtea-8-plugin icedtea-netx icedtea-netx-common 
    
  14. If Firefox 32 bit or Java or WebEx don't work, there may be missing dependencies. Try:

    sudo apt-get install libgtk-3-0:i386 libasound2:i386 libdbus-glib-1-2:i386 libxt6:i386 libxtst6:i386 libcanberra-gtk-module:i386 libcanberra-gtk3-module:i386 topmenu-gtk3:i386 libpangoxft-1.0-0:i386 libxft2:i386 libpangox-1.0-0:i386 libxmu6:i386 libxv1:i386 libasound2-plugins:i386
    
  • You can ask Cisco to activate the pure browser (plugin-free) web application for your organisation. Then when you join a meeting you will be able to join using this (or choose join using desktop for the previous method). However, as with the Chrome app, this lacks screen sharing currently (you can see others shared screens though). – mcarans Nov 13 '17 at 12:37
  • Thanks to this guide for the extra dependencies added into my answer above: gist.github.com/mshkrebtan/407786e334847544b40e7d6a8a53d247 – mcarans Apr 3 '18 at 15:01
  • Not working anymore I'm afraid – debuti Jan 30 at 9:22
  • You can just use WebEx through Chrome on Linux now - starting meetings and screen sharing work. – mcarans Jan 31 at 10:03
5

WebEx in VirtualBox

It might be wise to run WebEx inside a virtual machine such as VirtualBox. Without this security measure, the WebEx software will have unrestricted access to your system.

  1. Install VirtualBox:

    sudo apt install virtualbox
    
  2. Download a 32-bit (i386) Ubuntu ISO and optionally verify the ISO
  3. Install the 32-bit Ubuntu in VirtualBox and run these (and all following) commands there:

    sudo apt install virtualbox-guest-{dkms,utils,x11}
    sudo apt update
    sudo apt full-upgrade
    sudo apt autoremove
    sudo apt install libpangox-1.0-0
    

    Then reboot the guest OS.
    This enables host/guest shared clipboard, updates the software, and installs a WebEx dependency.

  4. Install Java

    • Alternative 1: OpenJDK

      sudo apt install icedtea-8-plugin
      

      To remove warnings about missing "Symantec Class 3 SHA256 Code Signing CA" certificate, get the certificate, save it as x.pem, and run:

      sudo keytool -importcert -file x.pem -keystore /etc/ssl/certs/java/cacerts -storepass changeit
      
    • Alternative 2: Oracle Java
      Oracle Java can be installed via the Web Upd8 Java PPA:

      sudo add-apt-repository ppa:webupd8team/java
      sudo apt update
      sudo apt install oracle-java8-installer
      
  5. Try a WebEx test meeting
  6. Check whether all dependencies are met:

    ldd ~/.webex/*/*.so | grep -i not
      libjawt.so => not found
      libjawt.so => not found
      libpangox-1.0.so.0 => not found
    

    libjawt.so can be ignored. The libpangox-1.0-0 package mentioned earlier should take care of libpangox-1.0.so.0.
    How to find packages containing any other missing files:

    sudo apt install apt-file
    sudo apt-file update
    apt-file search libpangox-1.0.so.0
    

Notes

Tested with Ubuntu 16.04 host and guest OS. Audio was only tested with Oracle Java.

libjawt.so is not shown as missing with this command:

LD_LIBRARY_PATH='/usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386:/usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server' ldd ~/.webex/*/*.so | grep -i not

Screenshot of the WebEx test meeting

screenshot

  • 1
    If you are going to run a virtual OS, it would be better to run Windows or OSX where WebEx support is much better but +1 for such a detailed explanation! – mcarans Aug 3 '17 at 6:26
  • You cannot run OSX legally in a VirtualBox unless it is installed in a Mac device. Read their EULA. – Fran Marzoa Feb 28 '18 at 15:48
  • running in a vm may make it more secure, and prevent you from having to downgrade to a 32bit FF, but it won't help for screen sharing from the originally intended host OS. – harschware Apr 24 '18 at 18:48

protected by Community Jul 18 '17 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.