8

My problem is that in the Global Keyboard Shortcuts appear two application launcher widgets and the "wrong one" is set back to ALT+F1 after each reboot.

Global Keyboard Shortcuts' image on my computer

I exported the scheme and I identified the widgets id:

activate widget 101=none
activate widget 2=Alt+F1

The wrong one is the number 2 when I changed 101 to this:

activate widget 101=Alt+F1
activate widget 2=none

Everything works, but I have to do that after every single reboot.

How I can leave only the working widget and delete the wrong widget?

Thanks in advance

3 Answers 3

12

I am on OpenSUSE 42.3 but found the following: I had to edit ~/.config/plasma-org.kde.plasma.desktop-appletsrc in addition to ~/.config/kglobalshortcutsrc. You will look for the widget number you want to delete (Widget 56 in my case), and then delete the referenced to that number (picture attached). In my case, I had to delete the entire [containments] section that the launcher was in ([Containments][21] in the picture), due to a panel that disappeared during a driver upgrade.

Screenshot of Application Launcher section

After that, I deleted the reference to the shortcut in ~/.config/kglobalshortcutsrc, then logged out. When I logged back in, I was able to set the shortcut as I wanted.

3
  • I'm using KDE neon 5.11, I did everything as instructed, same file locations and application launcher is now working, this answer took months of frustration away, thank you very much!
    – cumanacr
    Oct 15, 2017 at 4:02
  • This is still an issue it seems. Even on Ubuntu 19.04 after two years. Did some report this as a bug? Aug 9, 2019 at 12:33
  • Seems like the issue found it's way into Ubuntu 20.04. My solution was to remove all shortcut sections containing Alt+F1 from ~/.config/plasma-org.kde.plasma.desktop-appletsrc. I didn't edit ~/.config/kglobalshortcutsrc. After login out and back in, i could set the shortcut without any problem.
    – andred
    Sep 19, 2020 at 13:48
0

You may modify the shortcut key directly in ~/.config/kglobalshortcutsrc configuration file:

$ cat ~/.config/kglobalshortcutsrc | grep 'Activate Application Launcher Widget$'
activate widget 101=none,none,Activate Application Launcher Widget
activate widget 2=Alt+F1,none,Activate Application Launcher Widget

After modifying you should have something like this:

$ cat ~/.config/kglobalshortcutsrc | grep 'Activate Application Launcher Widget$'
activate widget 101=Alt+F1,none,Activate Application Launcher Widget
activate widget 2=none,none,Activate Application Launcher Widget

Then re-login.

2
  • 1
    I did it, but, after the reboot, it return to the previous values: $ cat ~/.config/kglobalshortcutsrc | grep 'Activate Application Launcher Widget$' activate widget 101=,none,Activate Application Launcher Widget activate widget 2=Alt+F1,none,Activate Application Launcher Widget
    – cumanacr
    Mar 15, 2017 at 18:11
  • 1
    Maybe change configuration file when not using KDE? So that it does not overwrite settings e.g. during logout etc.
    – Te Ri
    Aug 27, 2017 at 20:02
0

Right-click on the Start button, select "Configure Application Launcher...", Keyboard Shortcuts, assign it to Alt+F1.

Application Launcher Settings - Plasma Keyboard Shortcuts


Editing .config/kglobalshortcutsrc manually no longer works because there can be multiple application launcher widgets, one for each display (even if no longer connected), assigned randomly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.