16

I just installed GitKraken (A Git GUI) by downloading it from the website. When I try to install it via 'Discover Center', it doesn't work. So I found somewhere online the command dpkg -i [filename], used it on the gitkraken .deb, andddd MAGIC! It works!

I then tried to run GitKraken (by typing in gitkraken in the terminal), and that gave me this beautiful error:

Node started time: 1489531028950
libcurl.so.4: cannot open shared object file: No such file or directory
Error: libcurl.so.4: cannot open shared object file: No such file or directory
    at Error (native)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:158:20)
    at Object.Module._extensions..node (module.js:568:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:169:18)
    at Module.load (module.js:456:32)
    at tryModuleLoad (module.js:415:12)
    at Function.Module._load (module.js:407:3)
    at Module.require (module.js:466:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:11:12)
    at Module._compile (module.js:541:32)
    at Object.Module._extensions..js (module.js:550:10)
    at Module.load (module.js:456:32)
    at tryModuleLoad (module.js:415:12)
    at Function.Module._load (module.js:407:3)
    at Module.require (module.js:466:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/v1_5_0.js:7:17)
    at Module._compile (module.js:541:32)
    at Object.Module._extensions..js (module.js:550:10)
    at Module.load (module.js:456:32)
    at tryModuleLoad (module.js:415:12)
    at Function.Module._load (module.js:407:3)
    at Module.require (module.js:466:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/index.js:5:28)
    at Module._compile (module.js:541:32)
    at Object.Module._extensions..js (module.js:550:10)
    at Module.load (module.js:456:32)
    at tryModuleLoad (module.js:415:12)
    at Function.Module._load (module.js:407:3)
    at Module.require (module.js:466:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/index.js:7:24)
    at Module._compile (module.js:541:32)
    at Object.Module._extensions..js (module.js:550:10)
    at Module.load (module.js:456:32)
    at tryModuleLoad (module.js:415:12)
    at Function.Module._load (module.js:407:3)
    at Module.require (module.js:466:17)
    at require (internal/module.js:20:19)
    at EventEmitter.module.exports.app.on (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/main.js:146:5)
    at emitOne (events.js:101:20)
    at EventEmitter.emit (events.js:188:7)

Any help would be GREATLY appreciated.

14

In terminal...

  • sudo apt-get update
  • sudo apt-get install curl libcurl3

Now your app should work.

  • You are a lifesaver. – Matias K Mar 18 '17 at 3:27
8

I installed libgnome-keyring-common and libgnome-keyring-dev on ubuntu 16.04 which solved it for me:

sudo apt install libgnome-keyring-common libgnome-keyring-dev 
  • 1
    This works for distributions with a desktop environment not based on GNOME, such as Kubuntu. – Bruno Finger Oct 8 '18 at 8:04
  • 1
    this worked for me on Kubuntu as well! Thanks! – Brock Vond Nov 3 '18 at 21:42
1

I used the following command:

$ sudo apt-get install curl libcurl3 

and got the error below:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 curl : Depends: libcurl4 (= 7.58.0-2ubuntu3.8) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So I changed my command to:

$ sudo apt-get install curl libcurl4

And always remember to update packages before, as shown by Heynnema!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.