4

I understand that getting netflix to work on linux has been answered multiple times in many places. This question is a little different because:

  1. Firefox ended support for NPAPI plugins with firefox 52, so my usual solution of using pipelight with a user agent over-rider will no longer work
  2. Due to the inclusion of widevine on linux, this problem really shouldn't be happening.

First, my problem. It seems that netflix is unable to recognize that it should be using widevine. When I use a non-Windows UA, it tells me to install silverlight, when I use a Windows UA, it just sits at a black screen. I have tried numerous different UAs. Widevine is listed in about:plugins.

4
  • Are you by chance on a 32 bit system? Mar 14, 2017 at 1:45
  • With a fresh 16.04.2 install, Netflix wont play for me in Firefox 52. Installed Chrome and it worked without modification.
    – James
    Mar 14, 2017 at 2:41
  • I am on a 64bit system with 64 bit firefox.
    – Mitchell
    Mar 15, 2017 at 23:48
  • If you are on a 64 bit system, by far the easiest solution is to use Chrome. Mar 16, 2017 at 1:45

4 Answers 4

2

You can re-enable NPAPI support on Firefox 52 by opening about:config, adding the boolean preference plugin.load_flash_only and setting it to false.

(That's what keeps NPAPI support enabled for a few more months in Firefox ESR.)

Edit:

That preference stopped working with Firefox 54.

2
  • Unfortunately, that doesn't appear in my about:config.
    – Mitchell
    Mar 15, 2017 at 23:47
  • 1
    @Mitchell: No, you need to add it. Open about:config, scroll to the bottom, right click at the very bottom, select New -> Boolean. Mar 15, 2017 at 23:51
2

We have 2 Ubuntu 16.04 -computers at home and the Widevine seems to work just fine in Firefox 52 in the 64-bit version device and I can still watch Netflix and other sites that previously worked with Pipelight-plugins. However, in the 32-bit device it doesn´t, although Widevine is listed in Firefox-plugins. For a short-term solution, Gunnar Hjalmarsson´s advice worked.

I also installed Vivaldi + Widevine following these instructions: http://www.omgubuntu.co.uk/2016/07/watch-netflix-chromium-vivaldi. The correct script for 32-bit Linux is found from the comments, starting wget http://dist.control..., written by Ruari Ødegaard. I just copied the script and pasted it to the Terminal and started the installation.

Vivaldi/Widevine -solution actually worked, although the videostream looks a little bit abrupt. I don´t know if it´s because of Widevine or the laptop computer itself.

2

To run Netflix, Ubuntu 16.04 + Firefox 53 + Widevine plugin + VLC Media player works great, and I have had no issues running Netflix on a plain vanilla laptop. I found Netflix on Firefox did not work without VLC. I am guessing the VLC install will put the necessary video codecs on your machine. You also need to doublecheck that "Play DRM Content" is checked on Firefox (in the Preferences > Content section). I also found that Chrome 58 on Ubuntu 16.04 works fine as well. Hope this helps.

1
  • Installing the missing codecs did the job for me. In my case, I installed smplayer, can't really tell which codecs exactly Netflix/Widevine needs.
    – lipanski
    May 28, 2017 at 11:28
1

Try using Firefox ESR (Extended Support Release). It still supports plugins.

See https://www.mozilla.org/en-US/firefox/organizations/ for more information.

See https://www.mozilla.org/en-US/firefox/organizations/all/ for downloads.

Note: The Windows 64-bit version of Firefox 52 ESR only supports the Adobe Flash and Microsoft Silverlight plugins. If you also need support for Java or other plugins, choose the Windows (32-bit) download.*

*source: https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.