0

I am on Ubuntu 16.04 LTS, Dell XPS 15 9550.

Since one week ago (which probably matches last kernel update), every time I wake up my Laptop from suspend-mode, it correctly connects to the WiFi, but then it can't resolve any hostname (Google Chrome raises "DNS FINISHED BAD_CONFIG" and even ssh can't resolve server names).

This happen only when waking laptop up from suspend-mode. If I run

sudo service network-manager restart

then everything comes back to normal. I really have no idea of what's happening. Config or sys changes may be occurred only through automatic updates (kernel updates included).

P.S. I've already tried to reset resolvconf when the problem occurs, but no luck.

Thank you.

EDIT

just found this in syslog

brcmfmac 0000:02:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.txt failed with error -2

The strange thing is that I have an brcm/brcmfmac43602-pcie.bin in /lib/firmware , but it has extension .bin as all others drivers, so I don't know why the kernel is searching for an .txt file.

1

Same issue here on XPS13 9350 running Ubuntu GNOME 16.10.

I've found a solution/workaround, but I have to admit that I don't fully understand why it works.

I noticed that I kept seeing references to 127.0.1.1 as a nameserver, particularly in /etc/resolv.conf. Once I found that, it led me to the solution here:

nameserver 127.0.1.1 in resolv.conf won't go away!

The issue is with NetworkManager. It seems that it had the bogus notion that I was running a DNS server on my local machine, despite the fact that I don't. (This seems really silly as a default behavior, though, so I'm willing to concede I may have accidentally poked something or installed something that made it think so)

Regardless, it can be fixed by simply commenting out the following line in /etc/NetworkManager/NetworkManager.conf:

dns=dnsmasq

I've tried several reboots and sleep/wake cycles since making the change, all with positive results. I'll try to update this if I run into any future issues. Good Luck!

  • disabling NM's dnsmasq seems to be working fine! The only thing I dont understand is why this problem occurs only since last week (I am using Ubuntu 16.04 on Dell XPS 15 since April 2016). Is this the result of an apt upgrade, perhaps? Anyway, thank you! – user197675 Mar 15 '17 at 21:44
  • This was a fresh install for me, so I'm not really sure why it would just stop working correctly. /n can you check your apt logs to see what packages were upgraded around that time? It would probably have something to do with DNS. – osspuddles Apr 4 '17 at 16:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.