3

How to allow an account to login at the greeter without typing the password in Lubuntu 16.10?

I think I remember that worked in Ubuntu but I have not found a way to make that work in Lubuntu

GUI Try 1

I tried the gui way: "user & groups" -> change password -> [check] "don't ask password on login". And then reboot computer.

That doesn't work. The lightdm gtk greeter surely doesn't ask for a password for the user (let's say it is called user2), but then after I click ok, then the hard disk run for a while and then I go back to the login in screen again.

Original Config

/etc/lightdm/lightdm.conf:

[SeatDefaults]
# Check https://bugs.launchpad.net/lightdm/+bug/854261 before setting a timeout
user-session=Lubuntu
greeter-session=lightdm-gtk-greeter
allow-guest=false

Config File Try 1

I undo the gui try. Added the following lines to /etc/lightdm/lightdm.conf.d/20-lubuntu.conf, which was empty before I added these lines.

[SeatDefaults]
user-session=Lubuntu
autologin-user=user2
autologin-user-timeout=delay

I reboot the computer, and find that I still need to password to login at lightgreeter.

Config File Try 2

I undo other changes to the configuration files. Undo the gui try. I followed How to make Lubuntu login automatically?

Add the following lines to /etc/lightdm/lightdm.conf

[Seat:*]
pam-service=lightdm
pam-autologin-service=lightdm-autologin
autologin-user=user2
autologin-user-timeout=0

After that I reboot the computer. Still need password to login.

Config File Try 3

I undo other changes to the configuration files. Undo the gui try. I followed How to make Lubuntu login automatically?

add the following lines under the existing section [SeatDefaults] to /etc/lightdm/lightdm.conf,

autologin-user=user2
autologin-user-timeout=0
user-session=Lubuntu
greeter-session=lightdm-gtk-greeter

After that , I reboot the computer. Still need password for login.

Config File Try 4

I undo config file try 3, and didn't use the gui try. I back up /etc/lightdm/lightdm.conf to /etc/lightdm/lightdm.conf.orig and then replace /etc/lightdm/lightdm.conf with Organic Marble's config file:

[Seat:*]
autologin-guest = false
autologin-user = user2
autologin-user-timeout = 0

[SeatDefaults]
allow-guest = false

After that, I reboot the computer. Still need password to log in as user2 at the greeter.

New Account (Workaround 1)

I create a new account called user3. When I create it I choose not to encrypt homefolder, I also choose to login automatically before I actually log into the account. After that, automatic login on the account seems to work, so far.

I can try to replicate everything I did for user2 at the user3 account. But ideally, I should just click the checkbox for user2, and make autologin work for the existing account...

Summary

I don't know why only the gui way changes the behavior of the greeter (it makes the greeter doesn't ask for a password, but it also doesn't let me login. I certain hear some hard-disk noise for a few seconds though.).

  • how to figure out what went wrong? – hamster on wheels Mar 13 '17 at 17:51
  • Thought: you don't use whole disk or home folder encryption do you? – Organic Marble Mar 13 '17 at 18:22
  • I think I didn't use encryption. When I use my admin account and then sudo ls user2's home folder, I can see the contents. I can try to make a new account to test this. – hamster on wheels Mar 13 '17 at 18:26
  • Have you tried sudo passwd -d user2 (replace user2 with the correct username)? – heynnema Mar 13 '17 at 18:36
  • @heynnema I am not sure if removing the password is a good idea... unix.stackexchange.com/questions/7283/… – hamster on wheels Mar 13 '17 at 18:42
2

Here is one more to try. This is from a 16.04 system, not 16.10 but is proven to work there. This is the complete contents of my lightdm.conf file.

[Seat:*]
autologin-guest = false
autologin-user = user2
autologin-user-timeout = 0

[SeatDefaults]
allow-guest = false

Here is a complete lightdm.conf from a different 16.04 system, which also works.

[SeatDefaults]
autologin-user = user2
autologin-user-timeout = 0
user-session = Lubuntu
greeter-session = lightdm-gtk-greeter
allow-guest = false
0

If I understand correctly, GUI Try 1 only failed because after the screen slept you needed to log back in. That can be fixed by going to Settings -> Brightness and Lock -> uncheck require password in Ubuntu system settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.