1

I have three monitors, two of them are 3840x2160, the third is 1680x1050, all connected to an NVIDIA GTX980, using the proprietary driver (367.57).

The first of the 3840x2160 screens is connected to DVI-D-0, using a 2560x1440 resolution that is supported natively by DVI.

The second of the 3840x2160 screens is connected to DP-0, which does not (directly) support 2560x1440, but the nvidia settings tool allows me to simulate this resolution by using scaling within the video driver.

The third screen, right of those, is connected to DVI-I-0. The nvidia tool displays those monitors in the way I want them:

enter image description here

Note how the second monitor is selected and the resolution contains the word "scaled" due to the software scaling.

Checking these monitors using xrandr seems correct as well:

$ xrandr| grep ' connected'
DVI-I-0 connected 1680x1050+5120+0 (normal left inverted right x axis y axis) 433mm x 271mm
DP-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 621mm x 341mm
DVI-D-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 621mm x 341mm

However, when I maximize a window on the second screen, it gets maximized to 3840x2160, and xfce4-display-settings also seems to think the monitor has that resolution:

enter image description here

Also, the resolution dropdown list does not show the 2560x1440 mode, so I can't use that.

I assume this may be due to the fact that xrandr shows that monitor as using 2560x1440, but there that mode isn't listed in its available modes either:

$ xrandr
[snip]
DP-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 621mm x 341mm
   3840x2160     30.00*+
   1920x1080     60.00    60.00    59.94    50.00    50.00    60.00    50.04  
   1680x1050     59.95  
   1440x900      74.98    59.89  
[snip]

I tried to set the 2560x1440 resolution directly using xfce4-settings-editor, and changing ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml, but to no avail. After logging out/and back in, windows on the second display still maximize to 3840x2160, even though xfconf still has the smaller resolution I set using xfce4-settings-editor:

$ xfconf-query  -c displays -l -v
/Default/DP-0                 2. Philips Consumer Electronics Company 28"
/Default/DP-0/Active          true
/Default/DP-0/Position/X      2560
/Default/DP-0/Position/Y      0
/Default/DP-0/Primary         false
/Default/DP-0/Reflection      0
/Default/DP-0/RefreshRate     30,000000
/Default/DP-0/Resolution      2560x1440
/Default/DP-0/Rotation        0
/Default/DVI-D-0              3. Philips Consumer Electronics Company 28"
/Default/DVI-D-0/Active       true
/Default/DVI-D-0/Position/X   0
/Default/DVI-D-0/Position/Y   0
/Default/DVI-D-0/Primary      true
/Default/DVI-D-0/Reflection   0
/Default/DVI-D-0/RefreshRate  59,950550
/Default/DVI-D-0/Resolution   2560x1440
/Default/DVI-D-0/Rotation     0
/Default/DVI-I-0              1. BenQ 20"
/Default/DVI-I-0/Active       true
/Default/DVI-I-0/Position/X   5120
/Default/DVI-I-0/Position/Y   0
/Default/DVI-I-0/Primary      false
/Default/DVI-I-0/Reflection   0
/Default/DVI-I-0/RefreshRate  59,954250
/Default/DVI-I-0/Resolution   1680x1050
/Default/DVI-I-0/Rotation     0

So the question is: is there a way to make the desktop recognize that scaled resolution?

I used Ubuntu 14.04 LTS before, and didn't have this problem, it started when I upgraded to 16.04 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.