0

So I want to try and install a package that is available on Trusty (14.04) on Xenial. I have added the repositories for Trusty, and it finds the package and the dependencies while using 'apt list'. However, when I try to install (even with -f flag), it says I cannot find a package for 2 dependencies (libboost-mpi1.54-dev & libboost-mpi-python1.54-dev)

Anyone any idea how I can somehow force the installation of this package? Alternative is how to build boost 1.54 from source. But that one just keeps failing.

  • Adding Trusty's repositories to Xenial is a bad idea. What led you to do that? – Joseph Sible Mar 13 '17 at 18:32
  • The fact that the libboost1.54-all-dev package is available on Trusty and not on Xenial. I was hoping I could force install it that way. But no go it seems. – Herman VB Mar 15 '17 at 7:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.