4

I just bought two sandisk usb sticks, 16gb and 32gb, and used startup disk creator to install 16.04.02 from official site in both of them.

When I reboot my laptop with the any of the usbs inside, it just boots my current ubuntu installation. Nothing new.

This is my second time installing ubuntu on this machine from a flash drive, so I know it "should" work.

I've verified the installation file:

$ md5sum ubuntu-16.04.2-desktop-amd64.iso
1400884cec8e40a1a876b2678f81494b  ubuntu-16.04.2-desktop-amd64.iso

Matches the official hash

I've set the BIOS to boot first from USBs:

enter image description here

Following some threads on ask ubuntu and SO, here's what I've already tried and (hopefully) some relevant info:

info

Laptop: Acer Aspire V13 V3-372-57M8

$ sudo fdisk -l /dev/sdb1
Disk /dev/sdb1: 1.5 GiB, 1554186240 bytes, 3035520 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x15e2543d

Device      Boot Start     End Sectors  Size Id Type
/dev/sdb1p1 *        0 3035519 3035520  1.5G  0 Empty
/dev/sdb1p2      14432   19295    4864  2.4M ef EFI (FAT-12/16/32)

$ lsof /dev/sdb1 # this yields no output

$ sudo file -s /dev/sdb1
/dev/sdb1: DOS/MBR boot sector ISO 9660 CD-ROM filesystem data (DOS/MBR boot sector) 'Ubuntu 16.04.2 LTS amd64' (bootable); partition 2 : ID=0xef, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 14432, 4864 sectors

Things tried

Booting with secured boot disabled

$ sudo umount /dev/sdb1
$ sudo mkfs -t vfat /dev/sdb1
mkfs.fat 3.0.28 (2015-05-16)

and then using startup disk creator again, and rebooting. no luck.

Also tried wiping the usb with gparted, and creating a new NTFS partition and then using startup creator, no luck.

  • Did you try to install using another USB DOK (to make sure it isn't a problem with the USB DOK)? – Yaron Mar 13 '17 at 7:35
  • Which version of Ubuntu is running, when you run the Startup Disk Creator? Is it 16.04 LTS (or an earlier version)? Did you try with to put USB HDD as the highest priority? Did you try to turn off secure mode? Did you check with md5sum, that the downloaded iso file is good? Did you try in another computer? – sudodus Mar 13 '17 at 8:30
  • @Yaron DOK you mean another slot? Yes I've tried, all 3 slots. – Adam Goldman Mar 13 '17 at 12:24
  • @sudodus I'm running 16.04, I did try USB HDD at the top, disabling secure mode. did not check with md5sum, I downloaded from ubuntu official page. Did not try in another computer (dont have one here) – Adam Goldman Mar 13 '17 at 12:28
  • @AdamGoldman - did you try with another disk-on-key device? (not slot) – Yaron Mar 13 '17 at 12:35
1
+50

If you have a windows machine available I just used the Rufus app to make a bootable image.

http://rufus.akeo.ie/

https://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows

Not avail in Linux though. Only Windows.

NOTE: Also Like someone above said, depending on your USB Flash drive brand, there is a possibility for it to brick after making it bootable. I bricked mine after successfully installing 16.04 LTS. Theres a particular way to reverse the process if you want a normal drive back, which I didn't pay heed to, I just formatted it as normal and it bricked. I can't recall the link or method, DISKPART in windows to restore the MBR is one way. Otherwise it's probably safer to keep the USB bootable image as is.

Sorry if this is a vague answer, it was a "quick and nasty" way for me to install Lubuntu and my USB flash drive was an old cheapo disposable one. May or may not be suitable for your requirements.

Also in my BIOS, I used Legacy HDD IDE mode (No AHCI), No Secure Boot and No UEFI for it to install successfully after a couple times trying with other settings.

| improve this answer | |
  • Indeed I know about rufus, I'm trying to get access to a computer windows. not easy in the philippines! – Adam Goldman Mar 16 '17 at 11:36
  • switching to legacy mode did the trick! is there any drawback for installing in legacy mode? – Adam Goldman Mar 16 '17 at 12:06
  • If you have Windows installed in UEFI mode it is more convenient to install Ubuntu in UEFI mode too - makes it easier to switch between the two operating systems. But the computer will work well in both BIOS and UEFI mode. There is no drawback concerning stability or performance in BIOS mode. – sudodus Mar 16 '17 at 13:14
  • I found the IDE Legacy mode was only for allowing the initial install to go through. For some reason it doesn't work with AHCI on. You should be able turn back on the AHCI in BIOS after the install completes to get the faster HDD interface because Ubuntu does support it. I had no issues after doing this. – Sam Wheel Mar 16 '17 at 16:11
  • Well, unfortunately some manufacturers tweak the UEFI-BIOS system outside the standard specifications, and it can create problems for linux. – sudodus Mar 16 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.