0

I am new to XFCE and I am trying to get minecraft.jar to run, but I can't because it says I need to make it into an executable file (since XFCE deals with executables strangely, for security reasons i suppose) so I right-clicked the file and went into properties. When I went over to the properties tab, I couldn't find a checkbox to make it executable. Next, I tried to use terminal to make it executable using the chmod a+x minecraft.jar command, but it says that there is no such file with that name. Can anyone help?

  • 2
    You need to run the command in the same folder the file is in, otherwise you'll get that obvious error message. – user589808 Mar 13 '17 at 1:40
1

To make it executable, you need to specify your .jar files location:

chmod a+x /path/to/file.jar

Otherwise, you can also directly make it executable by right clicking the .jar file, go to the Permissions tab and check the Execute option.

Another ways to go is run the .jar files from terminal using java -jar command, as @Sadaharu pointed out:

java -jar /path/to/file.jar

Without having messing with executable thing, this is the easiest way.

0

First move file into your home folder.

change it executable with full path

chmod a+x ~/minecraft.jar

This should work now, execute in background add &

java -jar ~/minecraft.jar
  • 3
    /home isn't the user's home folder, and you don't need to set it executable to run it with java -jar. – Chai T. Rex Mar 13 '17 at 3:06
  • Wow, sorry I was a half asleep! – psw1747 Mar 13 '17 at 7:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.