1

Got an mini-itx (ASUS AT5NM10-I) computer that had Windows I want to try Ubuntu on. As I don't have a monitor with VGA input I'm using a VGA > HDMI adapter. The way the adapter works makes it show up as two separate displays.

I am able to install without problems. Ubuntu starts and I can see the login screen etc fine. But when I log in the display gets jumpled and then starts to flicker before going black. If i restart after this it won't show the login screen anymore, just some Ubuntu background or something.

I've searched for solutions online but haven't found any solution so far. If I understand it correctly it seems xrandr for some reason can't find or set up the Monitor/adapter properly? All commands I've tried so far fail with "Can't open display"

Some of what I've found while looking for a solution seems to suggest I could add the monitor(s) manually, but I am unsure how to do this correctly.

While writing this I'm actually using Ubuntu but from the USB drive I used to install. For some reason the preview Ubuntu there has no issue with this. Is it possible to somehow copy the configuration from the USB Ubuntu over to the installed Ubuntu?

Using USB drive ubuntu:

ubuntu@ubuntu:~$ xrandr --listmonitors

Monitors: 2

0: +*LVDS1 1280/344x720/194+0+0 LVDS1

1: +VGA1 1280/530x720/300+0+0 VGA1

  • You have to configure xrandr to work with the VGA to HDMI converter. I don't have my notes with me at work and the laptop is at home but, basically you run one program and get a line of numbers then you key it into a configuration file. – WinEunuuchs2Unix Mar 13 '17 at 19:36
  • Thanks! Can you tell me a bit more how to do it when you get a chance? Now I'm stuck using a 13 year old monitor since I can't get the adapter working :/ – Mortasi Mar 14 '17 at 18:01
  • I'll fire up the old laptop with the VGA to HDMI converter tonight and post an answer here. – WinEunuuchs2Unix Mar 14 '17 at 19:35
  • Thank you, but I just downloaded xubuntu 16.10 and did a clean install. Everything works perfectly including the adapter. If you haven't looked for your solution yet you can drop it unless you want to post it here for others. Think I'll just stick with xubuntu for now. – Mortasi Mar 14 '17 at 21:05
0

Nevermind. I bought an old monitor with VGA input and the same thing happens. Based on the log files i thought it was the adapter and multiple monitors that caused the problem, but now it has to be the driver.

I'd have thought intel integrated graphics on a motherboard would at least be able to start Ubuntu without any major issues.

I'll look around for solutions and post a new question if I can't get it working.

EDIT: I kinda had it right the first time it seems. I found this question which is very similar to my issue. When I installed tasksel and Xubuntu desktop it worked on my old VGA monitor using Unity. Could have been random chance though i guess.

Like the guy in the other post ubuntu shows two monitors, one built-in and one external. I thought this was the adapters doing but seems it's just the way it is.

EDIT2: Did a clean install again but with xubuntu. Everything works perfectly.

|improve this answer|||||
  • My Intel integrated graphics had no problem driving super VGA no problem. – WinEunuuchs2Unix Mar 13 '17 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.