0

When I try to move an icon, it just smoothly glides back to where I dragged it from. Sometimes though, after I've been logged on for a while, I can move icons and they'll stay where I put them. (I have no idea what changes this behavior.)

But the next time I log in, they're back to the upper left corner and they refuse to be dragged to a different spot on my desktop again.

-- edit -- There are 7 icons on the desktop; only 5 have icon files. File permissions and attributes:

jbland@joe-xlap2-64:~$ ls -l ~/.config/xfce4/desktop/ total 20 -rw-rw-r-- 1 jbland jbland 272 Mar 12 13:18 icons.screen0-1904x1039.rc -rw-rw-r-- 1 jbland jbland 333 Mar 12 20:47 icons.screen0-3158x1404.rc -rw-rw-r-- 1 jbland jbland 333 Mar 12 20:57 icons.screen0-3184x1404.rc -rw-rw-r-- 1 jbland jbland 330 Mar 12 20:47 icons.screen0-3184x758.rc -rw-rw-r-- 1 jbland jbland 330 Mar 12 16:56 icons.screen0-3184x759.rc jbland@joe-xlap2-64:~$ lsattr ~/.config/xfce4/desktop/ -------------e-- /home/jbland/.config/xfce4/desktop/icons.screen0-3158x1404.rc -------------e-- /home/jbland/.config/xfce4/desktop/icons.screen0-3184x759.rc -------------e-- /home/jbland/.config/xfce4/desktop/icons.screen0-3184x758.rc -------------e-- /home/jbland/.config/xfce4/desktop/icons.screen0-1904x1039.rc -------------e-- /home/jbland/.config/xfce4/desktop/icons.screen0-3184x1404.rc

While getting this information, I see now that I can position an icon as desired and an icon file gets updated. I have no idea why, in this same login session, I can now move icons successfully.

--edit 2-- So, I rebooted, and now I cannot move the icons once again. In addition, the Terminal and two other icons are gone. The attributes of the 5 files are unchanged.

  • The icon-positions are stored in the folder ~/.config/xfce4/desktop. Please run the commands ls -l ~/.config/xfce4/desktop and lsattr ~/.config/xfce4/desktop/* in terminal, copy the output,edit your question to paste the output of the commands. Just to see if file-permissions and attributes are correct. – mook765 Mar 14 '17 at 10:25
1

After wiping out the .config/xfce4 directory and starting over, I think I've figured out what's going on. It has to do with the alignment of dual monitors.

I have an external monitor on this laptop. If I extend the desktop and align the bottom of the laptop monitor (small) with the bottom of the external 27" monitor, things work great.

If instead I align them to reflect the real-world orientation where the laptop (primary) monitor is about 1/4 of the screen lower and on the left (which I'd prefer because it makes movement between monitors a lot smoother), that's when this behavior shows up. The tricky part is it doesn't show up until I log in again.

It appears that with this display orientation, something decides at login time that there are only three rows worth of icon space on the primary monitor (when there are actually still 7). Since there were icons below that, the whole desktop gets randomly rearranged. I can then move icons around as long as I only use the first three rows. If I try to use any row beyond that, the icon won't move. I can drag it there -- it just won't stick.

When I adjust the orientation of the two monitors, the number of apparent usable icon rows changes, even though there are no icons on the external monitor and the screen size of the primary monitor hasn't changed.

I only have full use of all icon rows if the two monitors are aligned at the bottom.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.