0

I am trying to fix my broken packages, one of them is ndiswrapper. It won't build due to an error in

$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up ndiswrapper-dkms (1.59-6) ...
Removing old ndiswrapper-1.59 DKMS files...

------------------------------
Deleting module version: 1.59
completely from the DKMS tree.
------------------------------
Done.
Loading new ndiswrapper-1.59 DKMS files...
First Installation: checking all kernels...
Building only for 4.8.0-41-generic
Building initial module for 4.8.0-41-generic
ERROR: Cannot create report: [Errno 17] File exists: 
'/var/crash/ndiswrapper-dkms.0.crash'
Error! Bad return status for module build on kernel: 4.8.0-41-generic 
(x86_64)
Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more 
information.
dpkg: error processing package ndiswrapper-dkms (--configure):
subprocess installed post-installation script returned error exit 
status 10
Errors were encountered while processing:
ndiswrapper-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

Here is /var/lib/dkms/ndiswrapper/1.59/build/make.log

http://pastebin.com/fpTDUxg2

How do I fix this?

1

You might try uninstalling your current ndiswrapper-dkms 1.59 and installing this:

http://mirrors.kernel.org/ubuntu/pool/universe/n/ndiswrapper/ndiswrapper-dkms_1.60-3~ubuntu16.04.1_all.deb

I was hoping to find one specific to 16.04.2, but this was the latest I could find.

ndiswrapper is very flaky anyway, and unless your really really need it, I'd just uninstall it.

1

Look at

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1651846

and

https://people.canonical.com/~ubuntu-archive/pending-sru.html -> changelog bug #1625089

and

https://launchpad.net/ubuntu/+source/ndiswrapper/

and

https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1625089

ndiswrapper is needed by the WLAN/WIFI driver. Without the DKMS-Module, WIFI/WLAN is broken.

v1.60 is in Ubuntu 16.10 and in the unstable repository of 16.04. Just wait, until 1.60 is in the stable repository and you will be able to use kernel v4.8 without any problems.

0

Download the latest version on https://sourceforge.net/projects/ndiswrapper/ and follow the steps on the INSTALL file. It worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy